Back to Multiple platform build/check report for BioC 3.14
A[B]CDEFGHIJKLMNOPQRSTUVWXYZ

This page was generated on 2022-01-24 13:05:54 -0500 (Mon, 24 Jan 2022).

HostnameOSArch (*)R versionInstalled pkgs
nebbiolo2Linux (Ubuntu 20.04.4 LTS)x86_644.1.2 (2021-11-01) -- "Bird Hippie" 4329
tokay2Windows Server 2012 R2 Standardx644.1.2 (2021-11-01) -- "Bird Hippie" 4080
machv2macOS 10.14.6 Mojavex86_644.1.2 (2021-11-01) -- "Bird Hippie" 4141
Click on any hostname to see more info about the system (e.g. compilers)      (*) as reported by 'uname -p', except on Windows and Mac OS X

CHECK results for basilisk on tokay2


To the developers/maintainers of the basilisk package:
- Please allow up to 24 hours (and sometimes 48 hours) for your latest push to git@git.bioconductor.org:packages/basilisk.git to
reflect on this report. See How and When does the builder pull? When will my changes propagate? here for more information.
- Make sure to use the following settings in order to reproduce any error or warning you see on this page.

raw results

Package 120/2083HostnameOS / ArchINSTALLBUILDCHECKBUILD BIN
basilisk 1.6.0  (landing page)
Aaron Lun
Snapshot Date: 2022-01-23 01:55:04 -0500 (Sun, 23 Jan 2022)
git_url: https://git.bioconductor.org/packages/basilisk
git_branch: RELEASE_3_14
git_last_commit: 8910ee2
git_last_commit_date: 2021-10-26 12:57:18 -0500 (Tue, 26 Oct 2021)
nebbiolo2Linux (Ubuntu 20.04.4 LTS) / x86_64  OK    OK    OK  UNNEEDED, same version is already published
tokay2Windows Server 2012 R2 Standard / x64  OK    OK    OK    OK  UNNEEDED, same version is already published
machv2macOS 10.14.6 Mojave / x86_64  OK    OK    OK    OK  UNNEEDED, same version is already published

Summary

Package: basilisk
Version: 1.6.0
Command: C:\Users\biocbuild\bbs-3.14-bioc\R\bin\R.exe --arch x64 CMD check --no-multiarch --install=check:basilisk.install-out.txt --library=C:\Users\biocbuild\bbs-3.14-bioc\R\library --no-vignettes --timings basilisk_1.6.0.tar.gz
StartedAt: 2022-01-23 15:37:14 -0500 (Sun, 23 Jan 2022)
EndedAt: 2022-01-23 15:59:26 -0500 (Sun, 23 Jan 2022)
EllapsedTime: 1331.7 seconds
RetCode: 0
Status:   OK  
CheckDir: basilisk.Rcheck
Warnings: 0

Command output

##############################################################################
##############################################################################
###
### Running command:
###
###   C:\Users\biocbuild\bbs-3.14-bioc\R\bin\R.exe --arch x64 CMD check --no-multiarch --install=check:basilisk.install-out.txt --library=C:\Users\biocbuild\bbs-3.14-bioc\R\library --no-vignettes --timings basilisk_1.6.0.tar.gz
###
##############################################################################
##############################################################################


* using log directory 'C:/Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck'
* using R version 4.1.2 (2021-11-01)
* using platform: x86_64-w64-mingw32 (64-bit)
* using session charset: ISO8859-1
* using option '--no-vignettes'
* checking for file 'basilisk/DESCRIPTION' ... OK
* this is package 'basilisk' version '1.6.0'
* checking package namespace information ... OK
* checking package dependencies ... OK
* checking if this is a source package ... OK
* checking if there is a namespace ... OK
* checking for hidden files and directories ... NOTE
Found the following hidden files and directories:
  inst/example/.BBSoptions
These were most likely included in error. See section 'Package
structure' in the 'Writing R Extensions' manual.
* checking for portable file names ... OK
* checking whether package 'basilisk' can be installed ... NOTE
Found the following notes/warnings:
  Non-staged installation was used
See 'C:/Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/00install.out' for details.
* checking installed package size ... OK
* checking package directory ... OK
* checking 'build' directory ... OK
* checking DESCRIPTION meta-information ... OK
* checking top-level files ... OK
* checking for left-over files ... OK
* checking index information ... OK
* checking package subdirectories ... OK
* checking R files for non-ASCII characters ... OK
* checking R files for syntax errors ... OK
* checking whether the package can be loaded ... OK
* checking whether the package can be loaded with stated dependencies ... OK
* checking whether the package can be unloaded cleanly ... OK
* checking whether the namespace can be loaded with stated dependencies ... OK
* checking whether the namespace can be unloaded cleanly ... OK
* checking dependencies in R code ... OK
* checking S3 generic/method consistency ... OK
* checking replacement functions ... OK
* checking foreign function calls ... OK
* checking R code for possible problems ... NOTE
basiliskRun: no visible binding for global variable '.basilisk.fun'
basiliskRun: no visible binding for global variable '.basilisk.args'
Undefined global functions or variables:
  .basilisk.args .basilisk.fun
* checking Rd files ... OK
* checking Rd metadata ... OK
* checking Rd cross-references ... OK
* checking for missing documentation entries ... OK
* checking for code/documentation mismatches ... OK
* checking Rd \usage sections ... OK
* checking Rd contents ... OK
* checking for unstated dependencies in examples ... OK
* checking line endings in shell scripts ... OK
* checking files in 'vignettes' ... OK
* checking examples ... OK
Examples with CPU (user + system) or elapsed time > 5s
                 user system elapsed
basiliskStart    1.32   0.63  357.42
setupBasiliskEnv 0.03   0.00   46.26
listPackages     0.01   0.00    6.16
* checking for unstated dependencies in 'tests' ... OK
* checking tests ...
  Running 'testthat.R'
 OK
* checking for unstated dependencies in vignettes ... OK
* checking package vignettes in 'inst/doc' ... OK
* checking running R code from vignettes ... SKIPPED
* checking re-building of vignette outputs ... SKIPPED
* checking PDF version of manual ... OK
* DONE

Status: 3 NOTEs
See
  'C:/Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/00check.log'
for details.



Installation output

basilisk.Rcheck/00install.out

##############################################################################
##############################################################################
###
### Running command:
###
###   C:\Users\biocbuild\bbs-3.14-bioc\R\bin\R.exe --arch x64 CMD INSTALL --no-multiarch basilisk
###
##############################################################################
##############################################################################


* installing to library 'C:/Users/biocbuild/bbs-3.14-bioc/R/library'
* installing *source* package 'basilisk' ...
** using non-staged installation via StagedInstall field
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
  converting help for package 'basilisk'
    finding HTML links ... done
    BasiliskEnvironment-class               html  
    PyPiLink                                html  
    basiliskOptions                         html  
    basiliskStart                           html  
    finding level-2 HTML links ... done

    configureBasiliskEnv                    html  
    findPersistentEnv                       html  
    listPackages                            html  
    setupBasiliskEnv                        html  
    useBasiliskEnv                          html  
** building package indices
** installing vignettes
** testing if installed package can be loaded
* DONE (basilisk)
Making 'packages.html' ... done

Tests output

basilisk.Rcheck/tests/testthat.Rout


R version 4.1.2 (2021-11-01) -- "Bird Hippie"
Copyright (C) 2021 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> library(testthat)
> library(basilisk)
> test_check("basilisk")
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - pandas=0.25.1
    - python-dateutil=2.8.0
    - python=3.7.7
    - pytz=2019.3


The following NEW packages will be INSTALLED:

  intel-openmp       conda-forge/win-64::intel-openmp-2022.0.0-h57928b3_3663
  libblas            conda-forge/win-64::libblas-3.9.0-13_win64_mkl
  libcblas           conda-forge/win-64::libcblas-3.9.0-13_win64_mkl
  liblapack          conda-forge/win-64::liblapack-3.9.0-13_win64_mkl
  mkl                conda-forge/win-64::mkl-2022.0.0-h0e2418a_796
  numpy              conda-forge/win-64::numpy-1.21.5-py37h5fa1a60_0
  pandas             pkgs/main/win-64::pandas-0.25.1-py37ha925a31_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.0-py_0
  pytz               conda-forge/noarch::pytz-2019.3-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0
  tbb                conda-forge/win-64::tbb-2021.5.0-h2d74725_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    pkgs/main::ca-certificates-2021.10.26~ --> conda-forge::ca-certificates-2021.10.8-h5b45459_0
  openssl              pkgs/main::openssl-1.1.1m-h2bbff1b_0 --> conda-forge::openssl-1.1.1l-h8ffe710_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - pandas=0.24.1
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  intel-openmp       conda-forge/win-64::intel-openmp-2022.0.0-h57928b3_3663
  libblas            conda-forge/win-64::libblas-3.9.0-13_win64_mkl
  libcblas           conda-forge/win-64::libcblas-3.9.0-13_win64_mkl
  liblapack          conda-forge/win-64::liblapack-3.9.0-13_win64_mkl
  mkl                conda-forge/win-64::mkl-2022.0.0-h0e2418a_796
  numpy              conda-forge/win-64::numpy-1.21.5-py37h5fa1a60_0
  pandas             pkgs/main/win-64::pandas-0.24.1-py37ha925a31_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0
  tbb                conda-forge/win-64::tbb-2021.5.0-h2d74725_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    pkgs/main::ca-certificates-2021.10.26~ --> conda-forge::ca-certificates-2021.10.8-h5b45459_0
  openssl              pkgs/main::openssl-1.1.1m-h2bbff1b_0 --> conda-forge::openssl-1.1.1l-h8ffe710_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=2.7


The following NEW packages will be INSTALLED:

  certifi            conda-forge/win-64::certifi-2019.11.28-py27h8c360ce_1
  pip                conda-forge/noarch::pip-20.1.1-pyh9f0ad1d_0
  python             conda-forge/win-64::python-2.7.15-h2880e7c_1011_cpython
  python_abi         conda-forge/win-64::python_abi-2.7-1_cp27m
  setuptools         conda-forge/win-64::setuptools-44.0.0-py27_0
  vc                 pkgs/main/win-64::vc-9-h2eaa2aa_6
  vs2008_runtime     conda-forge/win-64::vs2008_runtime-9.0.30729.6161-0
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0
  wincertstore       conda-forge/win-64::wincertstore-0.2-py27_1003


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=2.7


The following packages will be UPDATED:

  certifi            conda-forge/win-64::certifi-2019.11.2~ --> pkgs/main/noarch::certifi-2020.6.20-pyhd3eb1b0_3


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda



# All requested packages already installed.

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    pkgs/main::ca-certificates-2021.10.26~ --> conda-forge::ca-certificates-2021.10.8-h5b45459_0
  openssl              pkgs/main::openssl-1.1.1m-h2bbff1b_0 --> conda-forge::openssl-1.1.1l-h8ffe710_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting pandas==0.24.1
  Using cached pandas-0.24.1-cp37-cp37m-win_amd64.whl (9.0 MB)
Requirement already satisfied: pytz>=2011k in c:\users\biocbu~1\bbs-3~1.14-\meat\basili~1.rch\tests\testthat\instal~1\thingo\lib\site-packages (from pandas==0.24.1) (2018.7)
Requirement already satisfied: python-dateutil>=2.5.0 in c:\users\biocbu~1\bbs-3~1.14-\meat\basili~1.rch\tests\testthat\instal~1\thingo\lib\site-packages (from pandas==0.24.1) (2.7.1)
Collecting numpy>=1.12.0
  Using cached numpy-1.21.5-cp37-cp37m-win_amd64.whl (14.0 MB)
Requirement already satisfied: six>=1.5 in c:\users\biocbu~1\bbs-3~1.14-\meat\basili~1.rch\tests\testthat\instal~1\thingo\lib\site-packages (from python-dateutil>=2.5.0->pandas==0.24.1) (1.16.0)
Installing collected packages: numpy, pandas
  WARNING: The script f2py.exe is installed in 'C:\Users\BIOCBU~1\BBS-3~1.14-\meat\BASILI~1.RCH\tests\testthat\INSTAL~1\thingo\Scripts' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed numpy-1.21.5 pandas-0.24.1
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    pkgs/main::ca-certificates-2021.10.26~ --> conda-forge::ca-certificates-2021.10.8-h5b45459_0
  openssl              pkgs/main::openssl-1.1.1m-h2bbff1b_0 --> conda-forge::openssl-1.1.1l-h8ffe710_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Processing c:\users\biocbuild\bbs-3.14-bioc\r\library\basilisk\example\inst\test_dummy
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Building wheels for collected packages: test-dummy
  Building wheel for test-dummy (setup.py): started
  Building wheel for test-dummy (setup.py): finished with status 'done'
  Created wheel for test-dummy: filename=test_dummy-0.1-py3-none-any.whl size=1295 sha256=4430008fbf8005e61af67b2248bbb9f2a0134765e443e4a0d691319b957049c6
  Stored in directory: C:\Users\biocbuild\bbs-3.14-bioc\tmpdir\pip-ephem-wheel-cache-79v31jpj\wheels\2a\c2\90\4066dcbd81458ca0dfd9f365d828917097b5f5e2e119f88a5c
Successfully built test-dummy
Installing collected packages: test-dummy
Successfully installed test-dummy-0.1
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.

PackagesNotFoundError: The following packages are not available from current channels:

  - whheeeeeeeeeeeeeeeeee=0.0.1

Current channels:

  - https://conda.anaconda.org/conda-forge/win-64
  - https://conda.anaconda.org/conda-forge/noarch
  - https://repo.anaconda.com/pkgs/main/win-64
  - https://repo.anaconda.com/pkgs/main/noarch
  - https://repo.anaconda.com/pkgs/r/win-64
  - https://repo.anaconda.com/pkgs/r/noarch
  - https://repo.anaconda.com/pkgs/msys2/win-64
  - https://repo.anaconda.com/pkgs/msys2/noarch

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.


* installing *source* package 'son.of.basilisk' ...
** using non-staged installation via StagedInstall field
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
  converting help for package 'son.of.basilisk'
    finding HTML links ... done
    test                                    html  
** building package indices
** testing if installed package can be loaded
*** arch - i386
*** arch - x64
* DONE (son.of.basilisk)
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:30: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  method='lar', copy_X=True, eps=np.finfo(np.float).eps,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:167: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  method='lar', copy_X=True, eps=np.finfo(np.float).eps,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:284: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_Gram=True, verbose=0,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:862: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, fit_path=True,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:1101: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, fit_path=True,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:1127: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, positive=False):
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:1362: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  max_n_alphas=1000, n_jobs=None, eps=np.finfo(np.float).eps,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:1602: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  max_n_alphas=1000, n_jobs=None, eps=np.finfo(np.float).eps,
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\linear_model\least_angle.py:1738: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, positive=False):
C:\Users\BIOCBU~1\AppData\Local\R\cache\R\basilisk\1611D8~1.0\SONOF~1.BAS\099~1.0\env2\lib\site-packages\sklearn\decomposition\online_lda.py:29: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  EPS = np.finfo(np.float).eps
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\my_package_A

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\my_package_A

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\my_package_A

  added / updated specs:
    - pandas=0.25.1
    - python-dateutil=2.8.0
    - python=3.7.7
    - pytz=2019.3


The following NEW packages will be INSTALLED:

  intel-openmp       conda-forge/win-64::intel-openmp-2022.0.0-h57928b3_3663
  libblas            conda-forge/win-64::libblas-3.9.0-13_win64_mkl
  libcblas           conda-forge/win-64::libcblas-3.9.0-13_win64_mkl
  liblapack          conda-forge/win-64::liblapack-3.9.0-13_win64_mkl
  mkl                conda-forge/win-64::mkl-2022.0.0-h0e2418a_796
  numpy              conda-forge/win-64::numpy-1.21.5-py37h5fa1a60_0
  pandas             pkgs/main/win-64::pandas-0.25.1-py37ha925a31_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.0-py_0
  pytz               conda-forge/noarch::pytz-2019.3-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0
  tbb                conda-forge/win-64::tbb-2021.5.0-h2d74725_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    pkgs/main::ca-certificates-2021.10.26~ --> conda-forge::ca-certificates-2021.10.8-h5b45459_0
  openssl              pkgs/main::openssl-1.1.1m-h2bbff1b_0 --> conda-forge::openssl-1.1.1l-h8ffe710_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\my_package_B

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/win-64::ca-certificates-2021.10.8-h5b45459_0
  openssl            conda-forge/win-64::openssl-1.1.1l-h8ffe710_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/win-64::python-3.7.7-h81c818b_4
  python_abi         conda-forge/win-64::python_abi-3.7-2_cp37m
  setuptools         conda-forge/win-64::setuptools-60.5.0-py37h03978a9_0
  sqlite             conda-forge/win-64::sqlite-3.37.0-h8ffe710_0
  ucrt               conda-forge/win-64::ucrt-10.0.20348.0-h57928b3_0
  vc                 conda-forge/win-64::vc-14.2-hb210afc_6
  vs2015_runtime     conda-forge/win-64::vs2015_runtime-14.29.30037-h902a5da_6
  wheel              conda-forge/noarch::wheel-0.37.1-pyhd8ed1ab_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\my_package_B

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.10.26-haa95532_2
  openssl            conda-forge::openssl-1.1.1l-h8ffe710_0 --> pkgs/main::openssl-1.1.1m-h2bbff1b_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: C:\Users\biocbuild\bbs-3.14-bioc\meat\basilisk.Rcheck\tests\testthat\install-test-client\my_package_B

  added / updated specs:
    - pandas=0.24.1
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  intel-openmp       conda-forge/win-64::intel-openmp-2022.0.0-h57928b3_3663
  libblas            conda-forge/win-64::libblas-3.9.0-13_win64_mkl
  libcblas           conda-forge/win-64::libcblas-3.9.0-13_win64_mkl
  liblapack          conda-forge/win-64::liblapack-3.9.0-13_win64_mkl
  mkl                conda-forge/win-64::mkl-2022.0.0-h0e2418a_796
  numpy              conda-forge/win-64::numpy-1.21.5-py37h5fa1a60_0
  pandas             pkgs/main/win-64::pandas-0.24.1-py37ha925a31_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0
  tbb                conda-forge/win-64::tbb-2021.5.0-h2d74725_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    pkgs/main::ca-certificates-2021.10.26~ --> conda-forge::ca-certificates-2021.10.8-h5b45459_0
  openssl              pkgs/main::openssl-1.1.1m-h2bbff1b_0 --> conda-forge::openssl-1.1.1l-h8ffe710_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.11.0

Please update conda by running

    $ conda update -n base -c defaults conda


[ FAIL 0 | WARN 0 | SKIP 2 | PASS 37 ]

== Skipped tests ===============================================================
* On Windows (2)

[ FAIL 0 | WARN 0 | SKIP 2 | PASS 37 ]
> 
> proc.time()
   user  system elapsed 
   5.42   12.09  754.89 

Example timings

basilisk.Rcheck/basilisk-Ex.timings

nameusersystemelapsed
BasiliskEnvironment-class000
PyPiLink000
basiliskOptions000
basiliskStart 1.32 0.63357.42
configureBasiliskEnv0.020.000.02
findPersistentEnv0.050.004.70
listPackages0.010.006.16
setupBasiliskEnv 0.03 0.0046.26
useBasiliskEnv0.050.002.82