Back to Multiple platform build/check report for BioC 3.14
A[B]CDEFGHIJKLMNOPQRSTUVWXYZ

This page was generated on 2021-10-26 14:06:16 -0400 (Tue, 26 Oct 2021).

CHECK results for basilisk on nebbiolo2

To the developers/maintainers of the basilisk package:
- Please allow up to 24 hours (and sometimes 48 hours) for your latest push to git@git.bioconductor.org:packages/basilisk.git to
reflect on this report. See How and When does the builder pull? When will my changes propagate? here for more information.
- Make sure to use the following settings in order to reproduce any error or warning you see on this page.

raw results

Package 120/2083HostnameOS / ArchINSTALLBUILDCHECKBUILD BIN
basilisk 1.5.0  (landing page)
Aaron Lun
Snapshot Date: 2021-10-25 14:50:11 -0400 (Mon, 25 Oct 2021)
git_url: https://git.bioconductor.org/packages/basilisk
git_branch: master
git_last_commit: d4d0d26
git_last_commit_date: 2021-05-19 12:49:27 -0400 (Wed, 19 May 2021)
nebbiolo2Linux (Ubuntu 20.04.2 LTS) / x86_64  OK    OK    OK  UNNEEDED, same version is already published
riesling1Windows Server 2019 Standard / x64  OK    OK    OK    OK  UNNEEDED, same version is already published
merida1macOS 10.14.6 Mojave / x86_64  OK    OK    OK    OK  UNNEEDED, same version is already published
machv2macOS 10.14.6 Mojave / x86_64  OK    OK    OK    OK  

Summary

Package: basilisk
Version: 1.5.0
Command: /home/biocbuild/bbs-3.14-bioc/R/bin/R CMD check --install=check:basilisk.install-out.txt --library=/home/biocbuild/bbs-3.14-bioc/R/library --no-vignettes --timings basilisk_1.5.0.tar.gz
StartedAt: 2021-10-25 19:12:10 -0400 (Mon, 25 Oct 2021)
EndedAt: 2021-10-25 19:23:45 -0400 (Mon, 25 Oct 2021)
EllapsedTime: 694.2 seconds
RetCode: 0
Status:   OK  
CheckDir: basilisk.Rcheck
Warnings: 0

Command output

##############################################################################
##############################################################################
###
### Running command:
###
###   /home/biocbuild/bbs-3.14-bioc/R/bin/R CMD check --install=check:basilisk.install-out.txt --library=/home/biocbuild/bbs-3.14-bioc/R/library --no-vignettes --timings basilisk_1.5.0.tar.gz
###
##############################################################################
##############################################################################


* using log directory ‘/home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck’
* using R version 4.1.1 (2021-08-10)
* using platform: x86_64-pc-linux-gnu (64-bit)
* using session charset: UTF-8
* using option ‘--no-vignettes’
* checking for file ‘basilisk/DESCRIPTION’ ... OK
* this is package ‘basilisk’ version ‘1.5.0’
* checking package namespace information ... OK
* checking package dependencies ... OK
* checking if this is a source package ... OK
* checking if there is a namespace ... OK
* checking for hidden files and directories ... NOTE
Found the following hidden files and directories:
  inst/example/.BBSoptions
These were most likely included in error. See section ‘Package
structure’ in the ‘Writing R Extensions’ manual.
* checking for portable file names ... OK
* checking for sufficient/correct file permissions ... OK
* checking whether package ‘basilisk’ can be installed ... NOTE
Found the following notes/warnings:
  Non-staged installation was used
See ‘/home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/00install.out’ for details.
* checking installed package size ... OK
* checking package directory ... OK
* checking ‘build’ directory ... OK
* checking DESCRIPTION meta-information ... OK
* checking top-level files ... OK
* checking for left-over files ... OK
* checking index information ... OK
* checking package subdirectories ... OK
* checking R files for non-ASCII characters ... OK
* checking R files for syntax errors ... OK
* checking whether the package can be loaded ... OK
* checking whether the package can be loaded with stated dependencies ... OK
* checking whether the package can be unloaded cleanly ... OK
* checking whether the namespace can be loaded with stated dependencies ... OK
* checking whether the namespace can be unloaded cleanly ... OK
* checking dependencies in R code ... OK
* checking S3 generic/method consistency ... OK
* checking replacement functions ... OK
* checking foreign function calls ... OK
* checking R code for possible problems ... NOTE
basiliskRun: no visible binding for global variable ‘.basilisk.fun’
basiliskRun: no visible binding for global variable ‘.basilisk.args’
Undefined global functions or variables:
  .basilisk.args .basilisk.fun
* checking Rd files ... OK
* checking Rd metadata ... OK
* checking Rd cross-references ... OK
* checking for missing documentation entries ... OK
* checking for code/documentation mismatches ... OK
* checking Rd \usage sections ... OK
* checking Rd contents ... OK
* checking for unstated dependencies in examples ... OK
* checking line endings in shell scripts ... OK
* checking files in ‘vignettes’ ... OK
* checking examples ... OK
Examples with CPU (user + system) or elapsed time > 5s
                   user system elapsed
basiliskStart    77.698 12.548  93.315
setupBasiliskEnv 28.801  5.787  34.333
* checking for unstated dependencies in ‘tests’ ... OK
* checking tests ...
  Running ‘testthat.R’
 OK
* checking for unstated dependencies in vignettes ... OK
* checking package vignettes in ‘inst/doc’ ... OK
* checking running R code from vignettes ... SKIPPED
* checking re-building of vignette outputs ... SKIPPED
* checking PDF version of manual ... OK
* DONE

Status: 3 NOTEs
See
  ‘/home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/00check.log’
for details.



Installation output

basilisk.Rcheck/00install.out

##############################################################################
##############################################################################
###
### Running command:
###
###   /home/biocbuild/bbs-3.14-bioc/R/bin/R CMD INSTALL basilisk
###
##############################################################################
##############################################################################


* installing to library ‘/home/biocbuild/bbs-3.14-bioc/R/library’
* installing *source* package ‘basilisk’ ...
** using non-staged installation via StagedInstall field
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded
* DONE (basilisk)

Tests output

basilisk.Rcheck/tests/testthat.Rout


R version 4.1.1 (2021-08-10) -- "Kick Things"
Copyright (C) 2021 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> library(testthat)
> library(basilisk)
> test_check("basilisk")
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - pandas=0.25.1
    - python-dateutil=2.8.0
    - python=3.7.7
    - pytz=2019.3


The following NEW packages will be INSTALLED:

  libblas            conda-forge/linux-64::libblas-3.9.0-12_linux64_openblas
  libcblas           conda-forge/linux-64::libcblas-3.9.0-12_linux64_openblas
  libgfortran-ng     conda-forge/linux-64::libgfortran-ng-11.2.0-h69a702a_11
  libgfortran5       conda-forge/linux-64::libgfortran5-11.2.0-h5c6108e_11
  liblapack          conda-forge/linux-64::liblapack-3.9.0-12_linux64_openblas
  libopenblas        conda-forge/linux-64::libopenblas-0.3.18-pthreads_h8fe5266_0
  numpy              conda-forge/linux-64::numpy-1.21.3-py37h31617e3_0
  pandas             conda-forge/linux-64::pandas-0.25.1-py37hb3f55d8_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.0-py_0
  pytz               conda-forge/noarch::pytz-2019.3-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - pandas=0.24.1
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  libblas            conda-forge/linux-64::libblas-3.9.0-12_linux64_openblas
  libcblas           conda-forge/linux-64::libcblas-3.9.0-12_linux64_openblas
  libgfortran-ng     conda-forge/linux-64::libgfortran-ng-11.2.0-h69a702a_11
  libgfortran5       conda-forge/linux-64::libgfortran5-11.2.0-h5c6108e_11
  liblapack          conda-forge/linux-64::liblapack-3.9.0-12_linux64_openblas
  libopenblas        conda-forge/linux-64::libopenblas-0.3.18-pthreads_h8fe5266_0
  numpy              conda-forge/linux-64::numpy-1.21.3-py37h31617e3_0
  pandas             conda-forge/linux-64::pandas-0.24.1-py37hf484d3e_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=2.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  certifi            conda-forge/linux-64::certifi-2019.11.28-py27h8c360ce_1
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.2.1-he1b5a44_1007
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-20.1.1-pyh9f0ad1d_0
  python             conda-forge/linux-64::python-2.7.15-h5a48372_1011_cpython
  python_abi         conda-forge/linux-64::python_abi-2.7-1_cp27mu
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-44.0.0-py27_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=2.7


The following packages will be UPDATED:

  certifi            conda-forge/linux-64::certifi-2019.11~ --> pkgs/main/noarch::certifi-2020.6.20-pyhd3eb1b0_3
  python             conda-forge::python-2.7.15-h5a48372_1~ --> pkgs/main::python-2.7.18-h02575d3_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python[version='2.7.*,2.7.*']


The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  certifi            pkgs/main/noarch::certifi-2020.6.20-p~ --> conda-forge/linux-64::certifi-2016.9.26-py27_0
  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0
  python                pkgs/main::python-2.7.18-h02575d3_0 --> conda-forge::python-2.7.15-h5a48372_1011_cpython


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting pandas==0.24.1
  Using cached pandas-0.24.1-cp37-cp37m-manylinux1_x86_64.whl (10.1 MB)
Requirement already satisfied: python-dateutil>=2.5.0 in ./install-test-client/thingo/lib/python3.7/site-packages (from pandas==0.24.1) (2.7.1)
Requirement already satisfied: pytz>=2011k in ./install-test-client/thingo/lib/python3.7/site-packages (from pandas==0.24.1) (2018.7)
Collecting numpy>=1.12.0
  Using cached numpy-1.21.3-cp37-cp37m-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (15.7 MB)
Requirement already satisfied: six>=1.5 in ./install-test-client/thingo/lib/python3.7/site-packages (from python-dateutil>=2.5.0->pandas==0.24.1) (1.16.0)
Installing collected packages: numpy, pandas
Successfully installed numpy-1.21.3 pandas-0.24.1
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Processing /home/biocbuild/bbs-3.14-bioc/R/library/basilisk/example/inst/test_dummy
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Building wheels for collected packages: test-dummy
  Building wheel for test-dummy (setup.py): started
  Building wheel for test-dummy (setup.py): finished with status 'done'
  Created wheel for test-dummy: filename=test_dummy-0.1-py3-none-any.whl size=1295 sha256=d17ba65fc361466e3cf90e58631bc1a190b0cf1dd0f1b80886343ce37f1320e4
  Stored in directory: /tmp/pip-ephem-wheel-cache-7k01yhj_/wheels/d9/7e/45/9b9aae024f858d450e6b49da76fd7ad5dba98b806d9adf6c14
Successfully built test-dummy
Installing collected packages: test-dummy
Successfully installed test-dummy-0.1
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.

PackagesNotFoundError: The following packages are not available from current channels:

  - whheeeeeeeeeeeeeeeeee=0.0.1

Current channels:

  - https://conda.anaconda.org/conda-forge/linux-64
  - https://conda.anaconda.org/conda-forge/noarch
  - https://repo.anaconda.com/pkgs/main/linux-64
  - https://repo.anaconda.com/pkgs/main/noarch
  - https://repo.anaconda.com/pkgs/r/linux-64
  - https://repo.anaconda.com/pkgs/r/noarch

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.


trying URL 'https://repo.anaconda.com/miniconda/Miniconda3-py37_4.8.3-Linux-x86_64.sh'
Content type 'application/x-sh' length 88867207 bytes (84.8 MB)
==================================================
downloaded 84.8 MB

PREFIX=/tmp/RtmpzwgyWR/file1873ab48d7c7bc/1.5.0/0
Unpacking payload ...

  0%|          | 0/35 [00:00<?, ?it/s]
Extracting : tk-8.6.8-hbc83047_0.conda:   0%|          | 0/35 [00:00<?, ?it/s]
Extracting : tk-8.6.8-hbc83047_0.conda:   3%|▎         | 1/35 [00:00<00:09,  3.65it/s]
Extracting : ncurses-6.2-he6710b0_1.conda:   3%|▎         | 1/35 [00:00<00:09,  3.65it/s]
Extracting : ncurses-6.2-he6710b0_1.conda:   6%|▌         | 2/35 [00:00<00:07,  4.39it/s]
Extracting : ca-certificates-2020.1.1-0.conda:   6%|▌         | 2/35 [00:00<00:07,  4.39it/s]
Extracting : setuptools-46.4.0-py37_0.conda:   9%|▊         | 3/35 [00:00<00:07,  4.39it/s]  
Extracting : libgcc-ng-9.1.0-hdf63c60_0.conda:  11%|█▏        | 4/35 [00:00<00:07,  4.39it/s]
Extracting : pycparser-2.20-py_0.conda:  14%|█▍        | 5/35 [00:00<00:06,  4.39it/s]       
Extracting : libedit-3.1.20181209-hc058e9b_0.conda:  17%|█▋        | 6/35 [00:00<00:06,  4.39it/s]
Extracting : pysocks-1.7.1-py37_0.conda:  20%|██        | 7/35 [00:00<00:06,  4.39it/s]           
Extracting : openssl-1.1.1g-h7b6447c_0.conda:  23%|██▎       | 8/35 [00:00<00:06,  4.39it/s]
Extracting : pyopenssl-19.1.0-py37_0.conda:  26%|██▌       | 9/35 [00:00<00:05,  4.39it/s]  
Extracting : urllib3-1.25.8-py37_0.conda:  29%|██▊       | 10/35 [00:00<00:05,  4.39it/s] 
Extracting : sqlite-3.31.1-h62c20be_1.conda:  31%|███▏      | 11/35 [00:00<00:05,  4.39it/s]
Extracting : cryptography-2.9.2-py37h1ba5d50_0.conda:  34%|███▍      | 12/35 [00:00<00:05,  4.39it/s]
Extracting : pycosat-0.6.3-py37h7b6447c_0.conda:  37%|███▋      | 13/35 [00:00<00:05,  4.39it/s]     
Extracting : python-3.7.7-hcff3b4d_5.conda:  40%|████      | 14/35 [00:00<00:04,  4.39it/s]     
Extracting : python-3.7.7-hcff3b4d_5.conda:  43%|████▎     | 15/35 [00:00<00:03,  5.86it/s]
Extracting : cffi-1.14.0-py37he30daa8_1.conda:  43%|████▎     | 15/35 [00:00<00:03,  5.86it/s]
Extracting : _libgcc_mutex-0.1-main.conda:  46%|████▌     | 16/35 [00:00<00:03,  5.86it/s]    
Extracting : chardet-3.0.4-py37_1003.conda:  49%|████▊     | 17/35 [00:00<00:03,  5.86it/s]
Extracting : pip-20.0.2-py37_3.conda:  51%|█████▏    | 18/35 [00:00<00:02,  5.86it/s]      
Extracting : wheel-0.34.2-py37_0.conda:  54%|█████▍    | 19/35 [00:00<00:02,  5.86it/s]
Extracting : xz-5.2.5-h7b6447c_0.conda:  57%|█████▋    | 20/35 [00:00<00:02,  5.86it/s]
Extracting : zlib-1.2.11-h7b6447c_3.conda:  60%|██████    | 21/35 [00:00<00:02,  5.86it/s]
Extracting : libstdcxx-ng-9.1.0-hdf63c60_0.conda:  63%|██████▎   | 22/35 [00:00<00:02,  5.86it/s]
Extracting : libffi-3.3-he6710b0_1.conda:  66%|██████▌   | 23/35 [00:00<00:02,  5.86it/s]        
Extracting : ruamel_yaml-0.15.87-py37h7b6447c_0.conda:  69%|██████▊   | 24/35 [00:00<00:01,  5.86it/s]
Extracting : idna-2.9-py_1.conda:  71%|███████▏  | 25/35 [00:00<00:01,  5.86it/s]                     
Extracting : six-1.14.0-py37_0.conda:  74%|███████▍  | 26/35 [00:00<00:01,  5.86it/s]
Extracting : tqdm-4.46.0-py_0.conda:  77%|███████▋  | 27/35 [00:00<00:01,  5.86it/s] 
Extracting : conda-package-handling-1.6.1-py37h7b6447c_0.conda:  80%|████████  | 28/35 [00:00<00:01,  5.86it/s]
Extracting : certifi-2020.4.5.1-py37_0.conda:  83%|████████▎ | 29/35 [00:00<00:01,  5.86it/s]                  
Extracting : requests-2.23.0-py37_0.conda:  86%|████████▌ | 30/35 [00:00<00:00,  5.86it/s]   
Extracting : yaml-0.1.7-had09818_2.conda:  89%|████████▊ | 31/35 [00:00<00:00,  5.86it/s] 
Extracting : ld_impl_linux-64-2.33.1-h53a641e_7.conda:  91%|█████████▏| 32/35 [00:00<00:00,  5.86it/s]
Extracting : readline-8.0-h7b6447c_0.conda:  94%|█████████▍| 33/35 [00:00<00:00,  5.86it/s]           
Extracting : conda-4.8.3-py37_0.tar.bz2:  97%|█████████▋| 34/35 [00:00<00:00,  5.86it/s]   
                                                                                        
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /tmp/RtmpzwgyWR/file1873ab48d7c7bc/1.5.0/0

  added / updated specs:
    - _libgcc_mutex==0.1=main
    - ca-certificates==2020.1.1=0
    - certifi==2020.4.5.1=py37_0
    - cffi==1.14.0=py37he30daa8_1
    - chardet==3.0.4=py37_1003
    - conda-package-handling==1.6.1=py37h7b6447c_0
    - conda==4.8.3=py37_0
    - cryptography==2.9.2=py37h1ba5d50_0
    - idna==2.9=py_1
    - ld_impl_linux-64==2.33.1=h53a641e_7
    - libedit==3.1.20181209=hc058e9b_0
    - libffi==3.3=he6710b0_1
    - libgcc-ng==9.1.0=hdf63c60_0
    - libstdcxx-ng==9.1.0=hdf63c60_0
    - ncurses==6.2=he6710b0_1
    - openssl==1.1.1g=h7b6447c_0
    - pip==20.0.2=py37_3
    - pycosat==0.6.3=py37h7b6447c_0
    - pycparser==2.20=py_0
    - pyopenssl==19.1.0=py37_0
    - pysocks==1.7.1=py37_0
    - python==3.7.7=hcff3b4d_5
    - readline==8.0=h7b6447c_0
    - requests==2.23.0=py37_0
    - ruamel_yaml==0.15.87=py37h7b6447c_0
    - setuptools==46.4.0=py37_0
    - six==1.14.0=py37_0
    - sqlite==3.31.1=h62c20be_1
    - tk==8.6.8=hbc83047_0
    - tqdm==4.46.0=py_0
    - urllib3==1.25.8=py37_0
    - wheel==0.34.2=py37_0
    - xz==5.2.5=h7b6447c_0
    - yaml==0.1.7=had09818_2
    - zlib==1.2.11=h7b6447c_3


The following NEW packages will be INSTALLED:

  _libgcc_mutex      pkgs/main/linux-64::_libgcc_mutex-0.1-main
  ca-certificates    pkgs/main/linux-64::ca-certificates-2020.1.1-0
  certifi            pkgs/main/linux-64::certifi-2020.4.5.1-py37_0
  cffi               pkgs/main/linux-64::cffi-1.14.0-py37he30daa8_1
  chardet            pkgs/main/linux-64::chardet-3.0.4-py37_1003
  conda              pkgs/main/linux-64::conda-4.8.3-py37_0
  conda-package-han~ pkgs/main/linux-64::conda-package-handling-1.6.1-py37h7b6447c_0
  cryptography       pkgs/main/linux-64::cryptography-2.9.2-py37h1ba5d50_0
  idna               pkgs/main/noarch::idna-2.9-py_1
  ld_impl_linux-64   pkgs/main/linux-64::ld_impl_linux-64-2.33.1-h53a641e_7
  libedit            pkgs/main/linux-64::libedit-3.1.20181209-hc058e9b_0
  libffi             pkgs/main/linux-64::libffi-3.3-he6710b0_1
  libgcc-ng          pkgs/main/linux-64::libgcc-ng-9.1.0-hdf63c60_0
  libstdcxx-ng       pkgs/main/linux-64::libstdcxx-ng-9.1.0-hdf63c60_0
  ncurses            pkgs/main/linux-64::ncurses-6.2-he6710b0_1
  openssl            pkgs/main/linux-64::openssl-1.1.1g-h7b6447c_0
  pip                pkgs/main/linux-64::pip-20.0.2-py37_3
  pycosat            pkgs/main/linux-64::pycosat-0.6.3-py37h7b6447c_0
  pycparser          pkgs/main/noarch::pycparser-2.20-py_0
  pyopenssl          pkgs/main/linux-64::pyopenssl-19.1.0-py37_0
  pysocks            pkgs/main/linux-64::pysocks-1.7.1-py37_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  readline           pkgs/main/linux-64::readline-8.0-h7b6447c_0
  requests           pkgs/main/linux-64::requests-2.23.0-py37_0
  ruamel_yaml        pkgs/main/linux-64::ruamel_yaml-0.15.87-py37h7b6447c_0
  setuptools         pkgs/main/linux-64::setuptools-46.4.0-py37_0
  six                pkgs/main/linux-64::six-1.14.0-py37_0
  sqlite             pkgs/main/linux-64::sqlite-3.31.1-h62c20be_1
  tk                 pkgs/main/linux-64::tk-8.6.8-hbc83047_0
  tqdm               pkgs/main/noarch::tqdm-4.46.0-py_0
  urllib3            pkgs/main/linux-64::urllib3-1.25.8-py37_0
  wheel              pkgs/main/linux-64::wheel-0.34.2-py37_0
  xz                 pkgs/main/linux-64::xz-5.2.5-h7b6447c_0
  yaml               pkgs/main/linux-64::yaml-0.1.7-had09818_2
  zlib               pkgs/main/linux-64::zlib-1.2.11-h7b6447c_3


Preparing transaction: ...working... done
Executing transaction: ...working... done
installation finished.
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /tmp/RtmpzwgyWR/file1873ab48d7c7bc/1.5.0/basilisk.utils/1.5.0/test

  added / updated specs:
    - python=3.7.7


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    _libgcc_mutex-0.1          |      conda_forge           3 KB  conda-forge
    _openmp_mutex-4.5          |            1_gnu          22 KB  conda-forge
    ca-certificates-2021.10.8  |       ha878542_0         139 KB  conda-forge
    ld_impl_linux-64-2.36.1    |       hea4e1c9_2         667 KB  conda-forge
    libffi-3.3                 |       h58526e2_2          51 KB  conda-forge
    libgcc-ng-11.2.0           |      h1d223b6_11         887 KB  conda-forge
    libgomp-11.2.0             |      h1d223b6_11         427 KB  conda-forge
    libstdcxx-ng-11.2.0        |      he4da1e4_11         4.2 MB  conda-forge
    libzlib-1.2.11             |    h36c2ea0_1013          59 KB  conda-forge
    ncurses-6.2                |       h58526e2_4         985 KB  conda-forge
    openssl-1.1.1l             |       h7f98852_0         2.1 MB  conda-forge
    pip-21.3.1                 |     pyhd8ed1ab_0         1.2 MB  conda-forge
    python_abi-3.7             |          2_cp37m           4 KB  conda-forge
    readline-8.1               |       h46c0cb4_0         295 KB  conda-forge
    setuptools-58.2.0          |   py37h89c1867_0        1008 KB  conda-forge
    sqlite-3.36.0              |       h9cd32fc_2         1.4 MB  conda-forge
    tk-8.6.11                  |       h27826a3_1         3.3 MB  conda-forge
    wheel-0.37.0               |     pyhd8ed1ab_1          31 KB  conda-forge
    xz-5.2.5                   |       h516909a_1         343 KB  conda-forge
    zlib-1.2.11                |    h36c2ea0_1013          86 KB  conda-forge
    ------------------------------------------------------------
                                           Total:        17.1 MB

The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013



Downloading and Extracting Packages

readline-8.1         | 295 KB    |            |   0% 
readline-8.1         | 295 KB    | 5          |   5% 
readline-8.1         | 295 KB    | ########## | 100% 

tk-8.6.11            | 3.3 MB    |            |   0% 
tk-8.6.11            | 3.3 MB    | ########## | 100% 

_openmp_mutex-4.5    | 22 KB     |            |   0% 
_openmp_mutex-4.5    | 22 KB     | ########## | 100% 

ncurses-6.2          | 985 KB    |            |   0% 
ncurses-6.2          | 985 KB    | ########## | 100% 

wheel-0.37.0         | 31 KB     |            |   0% 
wheel-0.37.0         | 31 KB     | ########## | 100% 

setuptools-58.2.0    | 1008 KB   |            |   0% 
setuptools-58.2.0    | 1008 KB   | ########## | 100% 

_libgcc_mutex-0.1    | 3 KB      |            |   0% 
_libgcc_mutex-0.1    | 3 KB      | ########## | 100% 

libffi-3.3           | 51 KB     |            |   0% 
libffi-3.3           | 51 KB     | ########## | 100% 

ld_impl_linux-64-2.3 | 667 KB    |            |   0% 
ld_impl_linux-64-2.3 | 667 KB    | ########## | 100% 

xz-5.2.5             | 343 KB    |            |   0% 
xz-5.2.5             | 343 KB    | ########## | 100% 

libzlib-1.2.11       | 59 KB     |            |   0% 
libzlib-1.2.11       | 59 KB     | ########## | 100% 

libgomp-11.2.0       | 427 KB    |            |   0% 
libgomp-11.2.0       | 427 KB    | ########## | 100% 

pip-21.3.1           | 1.2 MB    |            |   0% 
pip-21.3.1           | 1.2 MB    | ########## | 100% 

libstdcxx-ng-11.2.0  | 4.2 MB    |            |   0% 
libstdcxx-ng-11.2.0  | 4.2 MB    | #########1 |  92% 
libstdcxx-ng-11.2.0  | 4.2 MB    | ########## | 100% 

sqlite-3.36.0        | 1.4 MB    |            |   0% 
sqlite-3.36.0        | 1.4 MB    | ########## | 100% 

python_abi-3.7       | 4 KB      |            |   0% 
python_abi-3.7       | 4 KB      | ########## | 100% 

libgcc-ng-11.2.0     | 887 KB    |            |   0% 
libgcc-ng-11.2.0     | 887 KB    | ########## | 100% 

zlib-1.2.11          | 86 KB     |            |   0% 
zlib-1.2.11          | 86 KB     | ########## | 100% 

openssl-1.1.1l       | 2.1 MB    |            |   0% 
openssl-1.1.1l       | 2.1 MB    | ########## | 100% 

ca-certificates-2021 | 139 KB    |            |   0% 
ca-certificates-2021 | 139 KB    | ########## | 100% 
Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /tmp/RtmpzwgyWR/file1873ab48d7c7bc/1.5.0/basilisk.utils/1.5.0/test
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /tmp/RtmpzwgyWR/file1873ab48d7c7bc/1.5.0/basilisk.utils/1.5.0/test

  added / updated specs:
    - python=3.7.7


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    ca-certificates-2021.9.30  |       h06a4308_1         116 KB
    openssl-1.1.1l             |       h7f8727e_0         2.5 MB
    ------------------------------------------------------------
                                           Total:         2.6 MB

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0



Downloading and Extracting Packages

ca-certificates-2021 | 116 KB    |            |   0% 
ca-certificates-2021 | 116 KB    | ########## | 100% 

openssl-1.1.1l       | 2.5 MB    |            |   0% 
openssl-1.1.1l       | 2.5 MB    | ########## | 100% 
Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /tmp/RtmpzwgyWR/file1873ab48d7c7bc/1.5.0/basilisk.utils/1.5.0/test

  added / updated specs:
    - pandas=0.25.1
    - python=3.7.7


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    libblas-3.9.0              |12_linux64_openblas          12 KB  conda-forge
    libcblas-3.9.0             |12_linux64_openblas          12 KB  conda-forge
    libgfortran-ng-11.2.0      |      h69a702a_11          19 KB  conda-forge
    libgfortran5-11.2.0        |      h5c6108e_11         1.7 MB  conda-forge
    liblapack-3.9.0            |12_linux64_openblas          12 KB  conda-forge
    libopenblas-0.3.18         |pthreads_h8fe5266_0         9.6 MB  conda-forge
    numpy-1.21.3               |   py37h31617e3_0         6.2 MB  conda-forge
    pandas-0.25.1              |   py37hb3f55d8_0        11.4 MB  conda-forge
    python-dateutil-2.8.2      |     pyhd8ed1ab_0         240 KB  conda-forge
    pytz-2021.3                |     pyhd8ed1ab_0         242 KB  conda-forge
    six-1.16.0                 |     pyh6c4a22f_0          14 KB  conda-forge
    ------------------------------------------------------------
                                           Total:        29.4 MB

The following NEW packages will be INSTALLED:

  libblas            conda-forge/linux-64::libblas-3.9.0-12_linux64_openblas
  libcblas           conda-forge/linux-64::libcblas-3.9.0-12_linux64_openblas
  libgfortran-ng     conda-forge/linux-64::libgfortran-ng-11.2.0-h69a702a_11
  libgfortran5       conda-forge/linux-64::libgfortran5-11.2.0-h5c6108e_11
  liblapack          conda-forge/linux-64::liblapack-3.9.0-12_linux64_openblas
  libopenblas        conda-forge/linux-64::libopenblas-0.3.18-pthreads_h8fe5266_0
  numpy              conda-forge/linux-64::numpy-1.21.3-py37h31617e3_0
  pandas             conda-forge/linux-64::pandas-0.25.1-py37hb3f55d8_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.2-pyhd8ed1ab_0
  pytz               conda-forge/noarch::pytz-2021.3-pyhd8ed1ab_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0



Downloading and Extracting Packages

libgfortran5-11.2.0  | 1.7 MB    |            |   0% 
libgfortran5-11.2.0  | 1.7 MB    | #5         |  15% 
libgfortran5-11.2.0  | 1.7 MB    | ########## | 100% 

pytz-2021.3          | 242 KB    |            |   0% 
pytz-2021.3          | 242 KB    | ########## | 100% 

liblapack-3.9.0      | 12 KB     |            |   0% 
liblapack-3.9.0      | 12 KB     | ########## | 100% 

libgfortran-ng-11.2. | 19 KB     |            |   0% 
libgfortran-ng-11.2. | 19 KB     | ########## | 100% 

numpy-1.21.3         | 6.2 MB    |            |   0% 
numpy-1.21.3         | 6.2 MB    | ######4    |  64% 
numpy-1.21.3         | 6.2 MB    | ########## | 100% 

libopenblas-0.3.18   | 9.6 MB    |            |   0% 
libopenblas-0.3.18   | 9.6 MB    | #####      |  50% 
libopenblas-0.3.18   | 9.6 MB    | ########## | 100% 

pandas-0.25.1        | 11.4 MB   |            |   0% 
pandas-0.25.1        | 11.4 MB   | ###6       |  36% 
pandas-0.25.1        | 11.4 MB   | ########5  |  85% 
pandas-0.25.1        | 11.4 MB   | ########## | 100% 

libcblas-3.9.0       | 12 KB     |            |   0% 
libcblas-3.9.0       | 12 KB     | ########## | 100% 

six-1.16.0           | 14 KB     |            |   0% 
six-1.16.0           | 14 KB     | ########## | 100% 

python-dateutil-2.8. | 240 KB    |            |   0% 
python-dateutil-2.8. | 240 KB    | ########## | 100% 

libblas-3.9.0        | 12 KB     |            |   0% 
libblas-3.9.0        | 12 KB     | ########## | 100% 
Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


* installing *source* package ‘son.of.basilisk’ ...
** using non-staged installation via StagedInstall field
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** testing if installed package can be loaded
* DONE (son.of.basilisk)
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:30: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  method='lar', copy_X=True, eps=np.finfo(np.float).eps,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:167: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  method='lar', copy_X=True, eps=np.finfo(np.float).eps,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:284: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_Gram=True, verbose=0,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:862: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, fit_path=True,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1101: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, fit_path=True,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1127: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, positive=False):
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1362: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  max_n_alphas=1000, n_jobs=None, eps=np.finfo(np.float).eps,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1602: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  max_n_alphas=1000, n_jobs=None, eps=np.finfo(np.float).eps,
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1738: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, positive=False):
/home/biocbuild/.cache/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/decomposition/online_lda.py:29: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  EPS = np.finfo(np.float).eps
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A

  added / updated specs:
    - pandas=0.25.1
    - python-dateutil=2.8.0
    - python=3.7.7
    - pytz=2019.3


The following NEW packages will be INSTALLED:

  libblas            conda-forge/linux-64::libblas-3.9.0-12_linux64_openblas
  libcblas           conda-forge/linux-64::libcblas-3.9.0-12_linux64_openblas
  libgfortran-ng     conda-forge/linux-64::libgfortran-ng-11.2.0-h69a702a_11
  libgfortran5       conda-forge/linux-64::libgfortran5-11.2.0-h5c6108e_11
  liblapack          conda-forge/linux-64::liblapack-3.9.0-12_linux64_openblas
  libopenblas        conda-forge/linux-64::libopenblas-0.3.18-pthreads_h8fe5266_0
  numpy              conda-forge/linux-64::numpy-1.21.3-py37h31617e3_0
  pandas             conda-forge/linux-64::pandas-0.25.1-py37hb3f55d8_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.0-py_0
  pytz               conda-forge/noarch::pytz-2019.3-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  _libgcc_mutex      conda-forge/linux-64::_libgcc_mutex-0.1-conda_forge
  _openmp_mutex      conda-forge/linux-64::_openmp_mutex-4.5-1_gnu
  ca-certificates    conda-forge/linux-64::ca-certificates-2021.10.8-ha878542_0
  ld_impl_linux-64   conda-forge/linux-64::ld_impl_linux-64-2.36.1-hea4e1c9_2
  libffi             conda-forge/linux-64::libffi-3.3-h58526e2_2
  libgcc-ng          conda-forge/linux-64::libgcc-ng-11.2.0-h1d223b6_11
  libgomp            conda-forge/linux-64::libgomp-11.2.0-h1d223b6_11
  libstdcxx-ng       conda-forge/linux-64::libstdcxx-ng-11.2.0-he4da1e4_11
  libzlib            conda-forge/linux-64::libzlib-1.2.11-h36c2ea0_1013
  ncurses            conda-forge/linux-64::ncurses-6.2-h58526e2_4
  openssl            conda-forge/linux-64::openssl-1.1.1l-h7f98852_0
  pip                conda-forge/noarch::pip-21.3.1-pyhd8ed1ab_0
  python             pkgs/main/linux-64::python-3.7.7-hcff3b4d_5
  python_abi         conda-forge/linux-64::python_abi-3.7-2_cp37m
  readline           conda-forge/linux-64::readline-8.1-h46c0cb4_0
  setuptools         conda-forge/linux-64::setuptools-58.2.0-py37h89c1867_0
  sqlite             conda-forge/linux-64::sqlite-3.36.0-h9cd32fc_2
  tk                 conda-forge/linux-64::tk-8.6.11-h27826a3_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/linux-64::xz-5.2.5-h516909a_1
  zlib               conda-forge/linux-64::zlib-1.2.11-h36c2ea0_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-h06a4308_1
  openssl            conda-forge::openssl-1.1.1l-h7f98852_0 --> pkgs/main::openssl-1.1.1l-h7f8727e_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /home/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B

  added / updated specs:
    - pandas=0.24.1
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  libblas            conda-forge/linux-64::libblas-3.9.0-12_linux64_openblas
  libcblas           conda-forge/linux-64::libcblas-3.9.0-12_linux64_openblas
  libgfortran-ng     conda-forge/linux-64::libgfortran-ng-11.2.0-h69a702a_11
  libgfortran5       conda-forge/linux-64::libgfortran5-11.2.0-h5c6108e_11
  liblapack          conda-forge/linux-64::liblapack-3.9.0-12_linux64_openblas
  libopenblas        conda-forge/linux-64::libopenblas-0.3.18-pthreads_h8fe5266_0
  numpy              conda-forge/linux-64::numpy-1.21.3-py37h31617e3_0
  pandas             conda-forge/linux-64::pandas-0.24.1-py37hf484d3e_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-ha878542_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h7f8727e_0 --> conda-forge::openssl-1.1.1l-h7f98852_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


[ FAIL 0 | WARN 0 | SKIP 0 | PASS 47 ]
> 
> proc.time()
   user  system elapsed 
449.100  57.981 526.536 

Example timings

basilisk.Rcheck/basilisk-Ex.timings

nameusersystemelapsed
BasiliskEnvironment-class0.0020.0000.002
PyPiLink000
basiliskOptions000
basiliskStart77.69812.54893.315
configureBasiliskEnv0.0070.0000.007
findPersistentEnv0.0340.0041.835
listPackages0.5870.1080.752
setupBasiliskEnv28.801 5.78734.333
useBasiliskEnv0.3890.0720.455