Back to Multiple platform build/check report for BioC 3.14
A[B]CDEFGHIJKLMNOPQRSTUVWXYZ

This page was generated on 2021-10-20 12:05:33 -0400 (Wed, 20 Oct 2021).

CHECK results for basilisk on merida1

To the developers/maintainers of the basilisk package:
- Please allow up to 24 hours (and sometimes 48 hours) for your latest push to git@git.bioconductor.org:packages/basilisk.git to
reflect on this report. See How and When does the builder pull? When will my changes propagate? here for more information.
- Make sure to use the following settings in order to reproduce any error or warning you see on this page.

raw results

Package 120/2072HostnameOS / ArchINSTALLBUILDCHECKBUILD BIN
basilisk 1.5.0  (landing page)
Aaron Lun
Snapshot Date: 2021-10-19 14:50:04 -0400 (Tue, 19 Oct 2021)
git_url: https://git.bioconductor.org/packages/basilisk
git_branch: master
git_last_commit: d4d0d26
git_last_commit_date: 2021-05-19 12:49:27 -0400 (Wed, 19 May 2021)
nebbiolo2Linux (Ubuntu 20.04.2 LTS) / x86_64  OK    OK    OK  UNNEEDED, same version is already published
riesling1Windows Server 2019 Standard / x64  OK    OK    OK    OK  UNNEEDED, same version is already published
merida1macOS 10.14.6 Mojave / x86_64  OK    OK    OK    OK  UNNEEDED, same version is already published

Summary

Package: basilisk
Version: 1.5.0
Command: /Library/Frameworks/R.framework/Resources/bin/R CMD check --install=check:basilisk.install-out.txt --library=/Library/Frameworks/R.framework/Resources/library --no-vignettes --timings basilisk_1.5.0.tar.gz
StartedAt: 2021-10-20 00:51:52 -0400 (Wed, 20 Oct 2021)
EndedAt: 2021-10-20 01:10:37 -0400 (Wed, 20 Oct 2021)
EllapsedTime: 1124.4 seconds
RetCode: 0
Status:   OK  
CheckDir: basilisk.Rcheck
Warnings: 0

Command output

##############################################################################
##############################################################################
###
### Running command:
###
###   /Library/Frameworks/R.framework/Resources/bin/R CMD check --install=check:basilisk.install-out.txt --library=/Library/Frameworks/R.framework/Resources/library --no-vignettes --timings basilisk_1.5.0.tar.gz
###
##############################################################################
##############################################################################


* using log directory ‘/Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck’
* using R version 4.1.1 Patched (2021-08-22 r80813)
* using platform: x86_64-apple-darwin17.0 (64-bit)
* using session charset: UTF-8
* using option ‘--no-vignettes’
* checking for file ‘basilisk/DESCRIPTION’ ... OK
* this is package ‘basilisk’ version ‘1.5.0’
* checking package namespace information ... OK
* checking package dependencies ... OK
* checking if this is a source package ... OK
* checking if there is a namespace ... OK
* checking for hidden files and directories ... NOTE
Found the following hidden files and directories:
  inst/example/.BBSoptions
These were most likely included in error. See section ‘Package
structure’ in the ‘Writing R Extensions’ manual.
* checking for portable file names ... OK
* checking for sufficient/correct file permissions ... OK
* checking whether package ‘basilisk’ can be installed ... NOTE
Found the following notes/warnings:
  Non-staged installation was used
See ‘/Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/00install.out’ for details.
* checking installed package size ... OK
* checking package directory ... OK
* checking ‘build’ directory ... OK
* checking DESCRIPTION meta-information ... OK
* checking top-level files ... OK
* checking for left-over files ... OK
* checking index information ... OK
* checking package subdirectories ... OK
* checking R files for non-ASCII characters ... OK
* checking R files for syntax errors ... OK
* checking whether the package can be loaded ... OK
* checking whether the package can be loaded with stated dependencies ... OK
* checking whether the package can be unloaded cleanly ... OK
* checking whether the namespace can be loaded with stated dependencies ... OK
* checking whether the namespace can be unloaded cleanly ... OK
* checking dependencies in R code ... OK
* checking S3 generic/method consistency ... OK
* checking replacement functions ... OK
* checking foreign function calls ... OK
* checking R code for possible problems ... NOTE
basiliskRun: no visible binding for global variable ‘.basilisk.fun’
basiliskRun: no visible binding for global variable ‘.basilisk.args’
Undefined global functions or variables:
  .basilisk.args .basilisk.fun
* checking Rd files ... OK
* checking Rd metadata ... OK
* checking Rd cross-references ... OK
* checking for missing documentation entries ... OK
* checking for code/documentation mismatches ... OK
* checking Rd \usage sections ... OK
* checking Rd contents ... OK
* checking for unstated dependencies in examples ... OK
* checking line endings in shell scripts ... OK
* checking files in ‘vignettes’ ... OK
* checking examples ... OK
Examples with CPU (user + system) or elapsed time > 5s
                    user system elapsed
basiliskStart    180.286 25.677 211.197
setupBasiliskEnv  37.487 10.152  47.489
* checking for unstated dependencies in ‘tests’ ... OK
* checking tests ...
  Running ‘testthat.R’
 OK
* checking for unstated dependencies in vignettes ... OK
* checking package vignettes in ‘inst/doc’ ... OK
* checking running R code from vignettes ... SKIPPED
* checking re-building of vignette outputs ... SKIPPED
* checking PDF version of manual ... OK
* DONE

Status: 3 NOTEs
See
  ‘/Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/00check.log’
for details.



Installation output

basilisk.Rcheck/00install.out

##############################################################################
##############################################################################
###
### Running command:
###
###   /Library/Frameworks/R.framework/Resources/bin/R CMD INSTALL basilisk
###
##############################################################################
##############################################################################


* installing to library ‘/Library/Frameworks/R.framework/Versions/4.1/Resources/library’
* installing *source* package ‘basilisk’ ...
** using non-staged installation via StagedInstall field
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** installing vignettes
** testing if installed package can be loaded
* DONE (basilisk)

Tests output

basilisk.Rcheck/tests/testthat.Rout


R version 4.1.1 Patched (2021-08-22 r80813) -- "Kick Things"
Copyright (C) 2021 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwin17.0 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> library(testthat)
> library(basilisk)
> test_check("basilisk")
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - pandas=0.25.1
    - python-dateutil=2.8.0
    - python=3.7.7
    - pytz=2019.3


The following NEW packages will be INSTALLED:

  libblas            conda-forge/osx-64::libblas-3.9.0-12_osx64_openblas
  libcblas           conda-forge/osx-64::libcblas-3.9.0-12_osx64_openblas
  libgfortran        conda-forge/osx-64::libgfortran-5.0.0-9_3_0_h6c81a4c_23
  libgfortran5       conda-forge/osx-64::libgfortran5-9.3.0-h6c81a4c_23
  liblapack          conda-forge/osx-64::liblapack-3.9.0-12_osx64_openblas
  libopenblas        conda-forge/osx-64::libopenblas-0.3.18-openmp_h3351f45_0
  llvm-openmp        conda-forge/osx-64::llvm-openmp-12.0.1-hda6cdc1_1
  numpy              conda-forge/osx-64::numpy-1.21.2-py37haefe36b_0
  pandas             conda-forge/osx-64::pandas-0.25.1-py37h86efe34_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.0-py_0
  pytz               conda-forge/noarch::pytz-2019.3-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - pandas=0.24.1
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  libblas            conda-forge/osx-64::libblas-3.9.0-12_osx64_openblas
  libcblas           conda-forge/osx-64::libcblas-3.9.0-12_osx64_openblas
  libgfortran        conda-forge/osx-64::libgfortran-5.0.0-9_3_0_h6c81a4c_23
  libgfortran5       conda-forge/osx-64::libgfortran5-9.3.0-h6c81a4c_23
  liblapack          conda-forge/osx-64::liblapack-3.9.0-12_osx64_openblas
  libopenblas        conda-forge/osx-64::libopenblas-0.3.18-openmp_h3351f45_0
  llvm-openmp        conda-forge/osx-64::llvm-openmp-12.0.1-hda6cdc1_1
  numpy              conda-forge/osx-64::numpy-1.21.2-py37haefe36b_0
  pandas             conda-forge/osx-64::pandas-0.24.1-py37h0a44026_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=2.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  certifi            conda-forge/osx-64::certifi-2019.11.28-py27h8c360ce_1
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.2.1-hb1e8313_1007
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-20.1.1-pyh9f0ad1d_0
  python             conda-forge/osx-64::python-2.7.15-h8e446fc_1011_cpython
  python_abi         conda-forge/osx-64::python_abi-2.7-1_cp27m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-44.0.0-py27_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=2.7


The following packages will be UPDATED:

  certifi            conda-forge/osx-64::certifi-2019.11.2~ --> pkgs/main/noarch::certifi-2020.6.20-pyhd3eb1b0_3
  python             conda-forge::python-2.7.15-h8e446fc_1~ --> pkgs/main::python-2.7.18-hc817775_0

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python[version='2.7.*,2.7.*']


The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  certifi            pkgs/main/noarch::certifi-2020.6.20-p~ --> conda-forge/osx-64::certifi-2016.9.26-py27_0
  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0
  python                pkgs/main::python-2.7.18-hc817775_0 --> conda-forge::python-2.7.15-h8e446fc_1011_cpython


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting pandas==0.24.1
  Using cached pandas-0.24.1-cp37-cp37m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (15.9 MB)
Collecting numpy>=1.12.0
  Using cached numpy-1.21.2-cp37-cp37m-macosx_10_9_x86_64.whl (16.9 MB)
Requirement already satisfied: python-dateutil>=2.5.0 in ./install-test-client/thingo/lib/python3.7/site-packages (from pandas==0.24.1) (2.7.1)
Requirement already satisfied: pytz>=2011k in ./install-test-client/thingo/lib/python3.7/site-packages (from pandas==0.24.1) (2018.7)
Requirement already satisfied: six>=1.5 in ./install-test-client/thingo/lib/python3.7/site-packages (from python-dateutil>=2.5.0->pandas==0.24.1) (1.16.0)
Installing collected packages: numpy, pandas
Successfully installed numpy-1.21.2 pandas-0.24.1
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Processing /Library/Frameworks/R.framework/Versions/4.1/Resources/library/basilisk/example/inst/test_dummy
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Building wheels for collected packages: test-dummy
  Building wheel for test-dummy (setup.py): started
  Building wheel for test-dummy (setup.py): finished with status 'done'
  Created wheel for test-dummy: filename=test_dummy-0.1-py3-none-any.whl size=1295 sha256=6f5d6aca25607ba492e3131d6a9c7de0740c5fcafdabcd1da8a7657dda493b4e
  Stored in directory: /private/tmp/pip-ephem-wheel-cache-0vw8bhye/wheels/f3/6d/f0/b11160875748d7c2ce9a1d318edd2ce1ae43d38e48930d5546
Successfully built test-dummy
Installing collected packages: test-dummy
Successfully installed test-dummy-0.1
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/thingo

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.

PackagesNotFoundError: The following packages are not available from current channels:

  - whheeeeeeeeeeeeeeeeee=0.0.1

Current channels:

  - https://conda.anaconda.org/conda-forge/osx-64
  - https://conda.anaconda.org/conda-forge/noarch
  - https://repo.anaconda.com/pkgs/main/osx-64
  - https://repo.anaconda.com/pkgs/main/noarch
  - https://repo.anaconda.com/pkgs/r/osx-64
  - https://repo.anaconda.com/pkgs/r/noarch

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.


trying URL 'https://repo.anaconda.com/miniconda/Miniconda3-py37_4.8.3-MacOSX-x86_64.sh'
Content type 'application/x-sh' length 54829425 bytes (52.3 MB)
==================================================
downloaded 52.3 MB

PREFIX=/tmp/Rtmp6XniwF/file13fb3b5e4372/1.5.0/0
Unpacking payload ...

  0%|          | 0/33 [00:00<?, ?it/s]
Extracting : ca-certificates-2020.1.1-0.conda:   0%|          | 0/33 [00:00<?, ?it/s]
Extracting : ca-certificates-2020.1.1-0.conda:   3%|▎         | 1/33 [00:00<00:26,  1.22it/s]
Extracting : certifi-2020.4.5.1-py37_0.conda:   3%|▎         | 1/33 [00:00<00:26,  1.22it/s] 
Extracting : cffi-1.14.0-py37hc512035_1.conda:   6%|▌         | 2/33 [00:00<00:25,  1.22it/s]
Extracting : chardet-3.0.4-py37_1003.conda:   9%|▉         | 3/33 [00:00<00:24,  1.22it/s]   
Extracting : chardet-3.0.4-py37_1003.conda:  12%|█▏        | 4/33 [00:00<00:16,  1.71it/s]
Extracting : conda-package-handling-1.6.1-py37h1de35cc_0.conda:  12%|█▏        | 4/33 [00:01<00:16,  1.71it/s]
Extracting : conda-package-handling-1.6.1-py37h1de35cc_0.conda:  15%|█▌        | 5/33 [00:01<00:12,  2.17it/s]
Extracting : cryptography-2.9.2-py37ha12b0ac_0.conda:  15%|█▌        | 5/33 [00:01<00:12,  2.17it/s]          
Extracting : cryptography-2.9.2-py37ha12b0ac_0.conda:  18%|█▊        | 6/33 [00:01<00:11,  2.35it/s]
Extracting : idna-2.9-py_1.conda:  18%|█▊        | 6/33 [00:01<00:11,  2.35it/s]                    
Extracting : libcxx-10.0.0-1.conda:  21%|██        | 7/33 [00:01<00:11,  2.35it/s]
Extracting : libedit-3.1.20181209-hb402a30_0.conda:  24%|██▍       | 8/33 [00:01<00:10,  2.35it/s]
Extracting : libffi-3.3-h0a44026_1.conda:  27%|██▋       | 9/33 [00:01<00:10,  2.35it/s]          
Extracting : ncurses-6.2-h0a44026_1.conda:  30%|███       | 10/33 [00:02<00:09,  2.35it/s]
Extracting : ncurses-6.2-h0a44026_1.conda:  33%|███▎      | 11/33 [00:02<00:08,  2.60it/s]
Extracting : openssl-1.1.1g-h1de35cc_0.conda:  33%|███▎      | 11/33 [00:02<00:08,  2.60it/s]
Extracting : pip-20.0.2-py37_3.conda:  36%|███▋      | 12/33 [00:02<00:08,  2.60it/s]        
Extracting : pycosat-0.6.3-py37h1de35cc_0.conda:  39%|███▉      | 13/33 [00:02<00:07,  2.60it/s]
Extracting : pycparser-2.20-py_0.conda:  42%|████▏     | 14/33 [00:02<00:07,  2.60it/s]         
Extracting : pyopenssl-19.1.0-py37_0.conda:  45%|████▌     | 15/33 [00:02<00:06,  2.60it/s]
Extracting : pysocks-1.7.1-py37_0.conda:  48%|████▊     | 16/33 [00:02<00:06,  2.60it/s]   
Extracting : python-3.7.7-hf48f09d_4.conda:  52%|█████▏    | 17/33 [00:03<00:06,  2.60it/s]
Extracting : python-3.7.7-hf48f09d_4.conda:  55%|█████▍    | 18/33 [00:03<00:04,  3.53it/s]
Extracting : python.app-2-py37_10.conda:  55%|█████▍    | 18/33 [00:03<00:04,  3.53it/s]   
Extracting : readline-8.0-h1de35cc_0.conda:  58%|█████▊    | 19/33 [00:03<00:03,  3.53it/s]
Extracting : requests-2.23.0-py37_0.conda:  61%|██████    | 20/33 [00:03<00:03,  3.53it/s] 
Extracting : ruamel_yaml-0.15.87-py37h1de35cc_0.conda:  64%|██████▎   | 21/33 [00:03<00:03,  3.53it/s]
Extracting : setuptools-46.4.0-py37_0.conda:  67%|██████▋   | 22/33 [00:03<00:03,  3.53it/s]          
Extracting : six-1.14.0-py37_0.conda:  70%|██████▉   | 23/33 [00:03<00:02,  3.53it/s]       
Extracting : sqlite-3.31.1-h5c1f38d_1.conda:  73%|███████▎  | 24/33 [00:03<00:02,  3.53it/s]
Extracting : tk-8.6.8-ha441bb4_0.conda:  76%|███████▌  | 25/33 [00:03<00:02,  3.53it/s]     
Extracting : tqdm-4.46.0-py_0.conda:  79%|███████▉  | 26/33 [00:03<00:01,  3.53it/s]   
Extracting : urllib3-1.25.8-py37_0.conda:  82%|████████▏ | 27/33 [00:03<00:01,  3.53it/s]
Extracting : wheel-0.34.2-py37_0.conda:  85%|████████▍ | 28/33 [00:03<00:01,  3.53it/s]  
Extracting : xz-5.2.5-h1de35cc_0.conda:  88%|████████▊ | 29/33 [00:03<00:01,  3.53it/s]
Extracting : yaml-0.1.7-hc338f04_2.conda:  91%|█████████ | 30/33 [00:03<00:00,  3.53it/s]
Extracting : zlib-1.2.11-h1de35cc_3.conda:  94%|█████████▍| 31/33 [00:03<00:00,  3.53it/s]
Extracting : conda-4.8.3-py37_0.tar.bz2:  97%|█████████▋| 32/33 [00:03<00:00,  3.53it/s]  
                                                                                        
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /tmp/Rtmp6XniwF/file13fb3b5e4372/1.5.0/0

  added / updated specs:
    - ca-certificates==2020.1.1=0
    - certifi==2020.4.5.1=py37_0
    - cffi==1.14.0=py37hc512035_1
    - chardet==3.0.4=py37_1003
    - conda-package-handling==1.6.1=py37h1de35cc_0
    - conda==4.8.3=py37_0
    - cryptography==2.9.2=py37ha12b0ac_0
    - idna==2.9=py_1
    - libcxx==10.0.0=1
    - libedit==3.1.20181209=hb402a30_0
    - libffi==3.3=h0a44026_1
    - ncurses==6.2=h0a44026_1
    - openssl==1.1.1g=h1de35cc_0
    - pip==20.0.2=py37_3
    - pycosat==0.6.3=py37h1de35cc_0
    - pycparser==2.20=py_0
    - pyopenssl==19.1.0=py37_0
    - pysocks==1.7.1=py37_0
    - python.app==2=py37_10
    - python==3.7.7=hf48f09d_4
    - readline==8.0=h1de35cc_0
    - requests==2.23.0=py37_0
    - ruamel_yaml==0.15.87=py37h1de35cc_0
    - setuptools==46.4.0=py37_0
    - six==1.14.0=py37_0
    - sqlite==3.31.1=h5c1f38d_1
    - tk==8.6.8=ha441bb4_0
    - tqdm==4.46.0=py_0
    - urllib3==1.25.8=py37_0
    - wheel==0.34.2=py37_0
    - xz==5.2.5=h1de35cc_0
    - yaml==0.1.7=hc338f04_2
    - zlib==1.2.11=h1de35cc_3


The following NEW packages will be INSTALLED:

  ca-certificates    pkgs/main/osx-64::ca-certificates-2020.1.1-0
  certifi            pkgs/main/osx-64::certifi-2020.4.5.1-py37_0
  cffi               pkgs/main/osx-64::cffi-1.14.0-py37hc512035_1
  chardet            pkgs/main/osx-64::chardet-3.0.4-py37_1003
  conda              pkgs/main/osx-64::conda-4.8.3-py37_0
  conda-package-han~ pkgs/main/osx-64::conda-package-handling-1.6.1-py37h1de35cc_0
  cryptography       pkgs/main/osx-64::cryptography-2.9.2-py37ha12b0ac_0
  idna               pkgs/main/noarch::idna-2.9-py_1
  libcxx             pkgs/main/osx-64::libcxx-10.0.0-1
  libedit            pkgs/main/osx-64::libedit-3.1.20181209-hb402a30_0
  libffi             pkgs/main/osx-64::libffi-3.3-h0a44026_1
  ncurses            pkgs/main/osx-64::ncurses-6.2-h0a44026_1
  openssl            pkgs/main/osx-64::openssl-1.1.1g-h1de35cc_0
  pip                pkgs/main/osx-64::pip-20.0.2-py37_3
  pycosat            pkgs/main/osx-64::pycosat-0.6.3-py37h1de35cc_0
  pycparser          pkgs/main/noarch::pycparser-2.20-py_0
  pyopenssl          pkgs/main/osx-64::pyopenssl-19.1.0-py37_0
  pysocks            pkgs/main/osx-64::pysocks-1.7.1-py37_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python.app         pkgs/main/osx-64::python.app-2-py37_10
  readline           pkgs/main/osx-64::readline-8.0-h1de35cc_0
  requests           pkgs/main/osx-64::requests-2.23.0-py37_0
  ruamel_yaml        pkgs/main/osx-64::ruamel_yaml-0.15.87-py37h1de35cc_0
  setuptools         pkgs/main/osx-64::setuptools-46.4.0-py37_0
  six                pkgs/main/osx-64::six-1.14.0-py37_0
  sqlite             pkgs/main/osx-64::sqlite-3.31.1-h5c1f38d_1
  tk                 pkgs/main/osx-64::tk-8.6.8-ha441bb4_0
  tqdm               pkgs/main/noarch::tqdm-4.46.0-py_0
  urllib3            pkgs/main/osx-64::urllib3-1.25.8-py37_0
  wheel              pkgs/main/osx-64::wheel-0.34.2-py37_0
  xz                 pkgs/main/osx-64::xz-5.2.5-h1de35cc_0
  yaml               pkgs/main/osx-64::yaml-0.1.7-hc338f04_2
  zlib               pkgs/main/osx-64::zlib-1.2.11-h1de35cc_3


Preparing transaction: ...working... done
Executing transaction: ...working... done
installation finished.
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /private/tmp/Rtmp6XniwF/file13fb3b5e4372/1.5.0/basilisk.utils/1.5.0/test

  added / updated specs:
    - python=3.7.7


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    ca-certificates-2021.10.8  |       h033912b_0         139 KB  conda-forge
    libcxx-12.0.1              |       habf9029_0         1.1 MB  conda-forge
    libffi-3.3                 |       h046ec9c_2          45 KB  conda-forge
    libzlib-1.2.11             |    h9173be1_1013          58 KB  conda-forge
    ncurses-6.2                |       h2e338ed_4         881 KB  conda-forge
    openssl-1.1.1l             |       h0d85af4_0         1.9 MB  conda-forge
    pip-21.3                   |     pyhd8ed1ab_0         1.2 MB  conda-forge
    python_abi-3.7             |          2_cp37m           4 KB  conda-forge
    readline-8.1               |       h05e3726_0         266 KB  conda-forge
    setuptools-58.2.0          |   py37hf985489_0         1.0 MB  conda-forge
    sqlite-3.36.0              |       h23a322b_2         1.8 MB  conda-forge
    tk-8.6.11                  |       h5dbffcc_1         3.3 MB  conda-forge
    wheel-0.37.0               |     pyhd8ed1ab_1          31 KB  conda-forge
    xz-5.2.5                   |       haf1e3a3_1         228 KB  conda-forge
    zlib-1.2.11                |    h9173be1_1013          87 KB  conda-forge
    ------------------------------------------------------------
                                           Total:        11.9 MB

The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013



Downloading and Extracting Packages

pip-21.3             | 1.2 MB    |            |   0% 
pip-21.3             | 1.2 MB    | ########## | 100% 

libzlib-1.2.11       | 58 KB     |            |   0% 
libzlib-1.2.11       | 58 KB     | ########## | 100% 

setuptools-58.2.0    | 1.0 MB    |            |   0% 
setuptools-58.2.0    | 1.0 MB    | ########## | 100% 

zlib-1.2.11          | 87 KB     |            |   0% 
zlib-1.2.11          | 87 KB     | ########## | 100% 

python_abi-3.7       | 4 KB      |            |   0% 
python_abi-3.7       | 4 KB      | ########## | 100% 

libcxx-12.0.1        | 1.1 MB    |            |   0% 
libcxx-12.0.1        | 1.1 MB    | ########## | 100% 

sqlite-3.36.0        | 1.8 MB    |            |   0% 
sqlite-3.36.0        | 1.8 MB    | ########## | 100% 

openssl-1.1.1l       | 1.9 MB    |            |   0% 
openssl-1.1.1l       | 1.9 MB    | ########## | 100% 

tk-8.6.11            | 3.3 MB    |            |   0% 
tk-8.6.11            | 3.3 MB    | ########## | 100% 

ncurses-6.2          | 881 KB    |            |   0% 
ncurses-6.2          | 881 KB    | ########## | 100% 

wheel-0.37.0         | 31 KB     |            |   0% 
wheel-0.37.0         | 31 KB     | ########## | 100% 

libffi-3.3           | 45 KB     |            |   0% 
libffi-3.3           | 45 KB     | ########## | 100% 

ca-certificates-2021 | 139 KB    |            |   0% 
ca-certificates-2021 | 139 KB    | ########## | 100% 

readline-8.1         | 266 KB    |            |   0% 
readline-8.1         | 266 KB    | ########## | 100% 

xz-5.2.5             | 228 KB    |            |   0% 
xz-5.2.5             | 228 KB    | ########## | 100% 
Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /private/tmp/Rtmp6XniwF/file13fb3b5e4372/1.5.0/basilisk.utils/1.5.0/test
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /private/tmp/Rtmp6XniwF/file13fb3b5e4372/1.5.0/basilisk.utils/1.5.0/test

  added / updated specs:
    - python=3.7.7


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    ca-certificates-2021.9.30  |       hecd8cb5_1         116 KB
    openssl-1.1.1l             |       h9ed2024_0         2.2 MB
    ------------------------------------------------------------
                                           Total:         2.3 MB

The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0



Downloading and Extracting Packages

openssl-1.1.1l       | 2.2 MB    |            |   0% 
openssl-1.1.1l       | 2.2 MB    | #########  |  91% 
openssl-1.1.1l       | 2.2 MB    | ########## | 100% 

ca-certificates-2021 | 116 KB    |            |   0% 
ca-certificates-2021 | 116 KB    | ########## | 100% 
Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /private/tmp/Rtmp6XniwF/file13fb3b5e4372/1.5.0/basilisk.utils/1.5.0/test

  added / updated specs:
    - pandas=0.25.1
    - python=3.7.7


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    libblas-3.9.0              |12_osx64_openblas          12 KB  conda-forge
    libcblas-3.9.0             |12_osx64_openblas          12 KB  conda-forge
    libgfortran-5.0.0          |9_3_0_h6c81a4c_23          19 KB  conda-forge
    libgfortran5-9.3.0         |      h6c81a4c_23         1.7 MB  conda-forge
    liblapack-3.9.0            |12_osx64_openblas          12 KB  conda-forge
    libopenblas-0.3.18         |openmp_h3351f45_0         9.0 MB  conda-forge
    llvm-openmp-12.0.1         |       hda6cdc1_1         287 KB  conda-forge
    numpy-1.21.2               |   py37haefe36b_0         5.8 MB  conda-forge
    pandas-0.25.1              |   py37h86efe34_0        10.2 MB  conda-forge
    python-dateutil-2.8.2      |     pyhd8ed1ab_0         240 KB  conda-forge
    pytz-2021.3                |     pyhd8ed1ab_0         242 KB  conda-forge
    six-1.16.0                 |     pyh6c4a22f_0          14 KB  conda-forge
    ------------------------------------------------------------
                                           Total:        27.5 MB

The following NEW packages will be INSTALLED:

  libblas            conda-forge/osx-64::libblas-3.9.0-12_osx64_openblas
  libcblas           conda-forge/osx-64::libcblas-3.9.0-12_osx64_openblas
  libgfortran        conda-forge/osx-64::libgfortran-5.0.0-9_3_0_h6c81a4c_23
  libgfortran5       conda-forge/osx-64::libgfortran5-9.3.0-h6c81a4c_23
  liblapack          conda-forge/osx-64::liblapack-3.9.0-12_osx64_openblas
  libopenblas        conda-forge/osx-64::libopenblas-0.3.18-openmp_h3351f45_0
  llvm-openmp        conda-forge/osx-64::llvm-openmp-12.0.1-hda6cdc1_1
  numpy              conda-forge/osx-64::numpy-1.21.2-py37haefe36b_0
  pandas             conda-forge/osx-64::pandas-0.25.1-py37h86efe34_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.2-pyhd8ed1ab_0
  pytz               conda-forge/noarch::pytz-2021.3-pyhd8ed1ab_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0



Downloading and Extracting Packages

libcblas-3.9.0       | 12 KB     |            |   0% 
libcblas-3.9.0       | 12 KB     | ########## | 100% 

python-dateutil-2.8. | 240 KB    |            |   0% 
python-dateutil-2.8. | 240 KB    | ########## | 100% 

pandas-0.25.1        | 10.2 MB   |            |   0% 
pandas-0.25.1        | 10.2 MB   | ###9       |  40% 
pandas-0.25.1        | 10.2 MB   | ########9  |  90% 
pandas-0.25.1        | 10.2 MB   | ########## | 100% 

libgfortran5-9.3.0   | 1.7 MB    |            |   0% 
libgfortran5-9.3.0   | 1.7 MB    | ########## | 100% 

libgfortran-5.0.0    | 19 KB     |            |   0% 
libgfortran-5.0.0    | 19 KB     | ########## | 100% 

numpy-1.21.2         | 5.8 MB    |            |   0% 
numpy-1.21.2         | 5.8 MB    | ######6    |  67% 
numpy-1.21.2         | 5.8 MB    | ########## | 100% 

six-1.16.0           | 14 KB     |            |   0% 
six-1.16.0           | 14 KB     | ########## | 100% 

liblapack-3.9.0      | 12 KB     |            |   0% 
liblapack-3.9.0      | 12 KB     | ########## | 100% 

pytz-2021.3          | 242 KB    |            |   0% 
pytz-2021.3          | 242 KB    | ########## | 100% 

libblas-3.9.0        | 12 KB     |            |   0% 
libblas-3.9.0        | 12 KB     | ########## | 100% 

libopenblas-0.3.18   | 9.0 MB    |            |   0% 
libopenblas-0.3.18   | 9.0 MB    | ####3      |  43% 
libopenblas-0.3.18   | 9.0 MB    | ########## | 100% 

llvm-openmp-12.0.1   | 287 KB    |            |   0% 
llvm-openmp-12.0.1   | 287 KB    | ########## | 100% 
Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


* installing *source* package ‘son.of.basilisk’ ...
** using non-staged installation via StagedInstall field
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** testing if installed package can be loaded
* DONE (son.of.basilisk)
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:30: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  method='lar', copy_X=True, eps=np.finfo(np.float).eps,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:167: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  method='lar', copy_X=True, eps=np.finfo(np.float).eps,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:284: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_Gram=True, verbose=0,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:862: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, fit_path=True,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1101: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, fit_path=True,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1127: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, positive=False):
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1362: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  max_n_alphas=1000, n_jobs=None, eps=np.finfo(np.float).eps,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1602: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  max_n_alphas=1000, n_jobs=None, eps=np.finfo(np.float).eps,
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/linear_model/least_angle.py:1738: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  eps=np.finfo(np.float).eps, copy_X=True, positive=False):
/Users/biocbuild/Library/Caches/org.R-project.R/R/basilisk/1.5.0/son.of.basilisk/0.99.0/env2/lib/python3.7/site-packages/sklearn/decomposition/online_lda.py:29: DeprecationWarning: `np.float` is a deprecated alias for the builtin `float`. To silence this warning, use `float` by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use `np.float64` here.
Deprecated in NumPy 1.20; for more details and guidance: https://numpy.org/devdocs/release/1.20.0-notes.html#deprecations
  EPS = np.finfo(np.float).eps
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_A

  added / updated specs:
    - pandas=0.25.1
    - python-dateutil=2.8.0
    - python=3.7.7
    - pytz=2019.3


The following NEW packages will be INSTALLED:

  libblas            conda-forge/osx-64::libblas-3.9.0-12_osx64_openblas
  libcblas           conda-forge/osx-64::libcblas-3.9.0-12_osx64_openblas
  libgfortran        conda-forge/osx-64::libgfortran-5.0.0-9_3_0_h6c81a4c_23
  libgfortran5       conda-forge/osx-64::libgfortran5-9.3.0-h6c81a4c_23
  liblapack          conda-forge/osx-64::liblapack-3.9.0-12_osx64_openblas
  libopenblas        conda-forge/osx-64::libopenblas-0.3.18-openmp_h3351f45_0
  llvm-openmp        conda-forge/osx-64::llvm-openmp-12.0.1-hda6cdc1_1
  numpy              conda-forge/osx-64::numpy-1.21.2-py37haefe36b_0
  pandas             conda-forge/osx-64::pandas-0.25.1-py37h86efe34_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.8.0-py_0
  pytz               conda-forge/noarch::pytz-2019.3-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B

  added / updated specs:
    - python=3.7.7


The following NEW packages will be INSTALLED:

  ca-certificates    conda-forge/osx-64::ca-certificates-2021.10.8-h033912b_0
  libcxx             conda-forge/osx-64::libcxx-12.0.1-habf9029_0
  libffi             conda-forge/osx-64::libffi-3.3-h046ec9c_2
  libzlib            conda-forge/osx-64::libzlib-1.2.11-h9173be1_1013
  ncurses            conda-forge/osx-64::ncurses-6.2-h2e338ed_4
  openssl            conda-forge/osx-64::openssl-1.1.1l-h0d85af4_0
  pip                conda-forge/noarch::pip-21.3-pyhd8ed1ab_0
  python             pkgs/main/osx-64::python-3.7.7-hf48f09d_4
  python_abi         conda-forge/osx-64::python_abi-3.7-2_cp37m
  readline           conda-forge/osx-64::readline-8.1-h05e3726_0
  setuptools         conda-forge/osx-64::setuptools-58.2.0-py37hf985489_0
  sqlite             conda-forge/osx-64::sqlite-3.36.0-h23a322b_2
  tk                 conda-forge/osx-64::tk-8.6.11-h5dbffcc_1
  wheel              conda-forge/noarch::wheel-0.37.0-pyhd8ed1ab_1
  xz                 conda-forge/osx-64::xz-5.2.5-haf1e3a3_1
  zlib               conda-forge/osx-64::zlib-1.2.11-h9173be1_1013


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


#
# To activate this environment, use
#
#     $ conda activate /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B
#
# To deactivate an active environment, use
#
#     $ conda deactivate

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B

  added / updated specs:
    - python=3.7.7


The following packages will be SUPERSEDED by a higher-priority channel:

  ca-certificates    conda-forge::ca-certificates-2021.10.~ --> pkgs/main::ca-certificates-2021.9.30-hecd8cb5_1
  openssl            conda-forge::openssl-1.1.1l-h0d85af4_0 --> pkgs/main::openssl-1.1.1l-h9ed2024_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... done

## Package Plan ##

  environment location: /Users/biocbuild/bbs-3.14-bioc/meat/basilisk.Rcheck/tests/testthat/install-test-client/my_package_B

  added / updated specs:
    - pandas=0.24.1
    - python-dateutil=2.7.1
    - python=3.7.7
    - pytz=2018.7


The following NEW packages will be INSTALLED:

  libblas            conda-forge/osx-64::libblas-3.9.0-12_osx64_openblas
  libcblas           conda-forge/osx-64::libcblas-3.9.0-12_osx64_openblas
  libgfortran        conda-forge/osx-64::libgfortran-5.0.0-9_3_0_h6c81a4c_23
  libgfortran5       conda-forge/osx-64::libgfortran5-9.3.0-h6c81a4c_23
  liblapack          conda-forge/osx-64::liblapack-3.9.0-12_osx64_openblas
  libopenblas        conda-forge/osx-64::libopenblas-0.3.18-openmp_h3351f45_0
  llvm-openmp        conda-forge/osx-64::llvm-openmp-12.0.1-hda6cdc1_1
  numpy              conda-forge/osx-64::numpy-1.21.2-py37haefe36b_0
  pandas             conda-forge/osx-64::pandas-0.24.1-py37h0a44026_0
  python-dateutil    conda-forge/noarch::python-dateutil-2.7.1-py_0
  pytz               conda-forge/noarch::pytz-2018.7-py_0
  six                conda-forge/noarch::six-1.16.0-pyh6c4a22f_0

The following packages will be UPDATED:

  ca-certificates    pkgs/main::ca-certificates-2021.9.30-~ --> conda-forge::ca-certificates-2021.10.8-h033912b_0

The following packages will be SUPERSEDED by a higher-priority channel:

  openssl              pkgs/main::openssl-1.1.1l-h9ed2024_0 --> conda-forge::openssl-1.1.1l-h0d85af4_0


Preparing transaction: ...working... done
Verifying transaction: ...working... done
Executing transaction: ...working... done


==> WARNING: A newer version of conda exists. <==
  current version: 4.8.3
  latest version: 4.10.3

Please update conda by running

    $ conda update -n base -c defaults conda


[ FAIL 0 | WARN 0 | SKIP 0 | PASS 47 ]
> 
> proc.time()
   user  system elapsed 
592.115 137.242 769.741 

Example timings

basilisk.Rcheck/basilisk-Ex.timings

nameusersystemelapsed
BasiliskEnvironment-class0.0040.0000.005
PyPiLink000
basiliskOptions0.0000.0010.000
basiliskStart180.286 25.677211.197
configureBasiliskEnv0.0080.0010.008
findPersistentEnv0.0450.0113.742
listPackages1.2090.4301.697
setupBasiliskEnv37.48710.15247.489
useBasiliskEnv0.8080.3681.184