Back to Multiple platform build/check report for BioC 3.15
AB[C]DEFGHIJKLMNOPQRSTUVWXYZ

This page was generated on 2021-11-30 13:54:47 -0500 (Tue, 30 Nov 2021).

INSTALL results for ChAMP on riesling1

To the developers/maintainers of the ChAMP package:
- Please allow up to 24 hours (and sometimes 48 hours) for your latest push to git@git.bioconductor.org:packages/ChAMP.git to
reflect on this report. See How and When does the builder pull? When will my changes propagate? here for more information.
- Make sure to use the following settings in order to reproduce any error or warning you see on this page.

raw results

Package 287/2068HostnameOS / ArchINSTALLBUILDCHECKBUILD BIN
ChAMP 2.25.0  (landing page)
Yuan Tian
Snapshot Date: 2021-11-29 14:50:17 -0500 (Mon, 29 Nov 2021)
git_url: https://git.bioconductor.org/packages/ChAMP
git_branch: master
git_last_commit: f25a72d
git_last_commit_date: 2021-10-26 12:10:43 -0500 (Tue, 26 Oct 2021)
nebbiolo1Linux (Ubuntu 20.04.3 LTS) / x86_64  OK    OK    WARNINGS  UNNEEDED, same version is already published
riesling1Windows Server 2019 Standard / x64  OK    OK    WARNINGS    OK  
merida1macOS 10.14.6 Mojave / x86_64  OK    OK    WARNINGS    OK  NO, package depends on 'DMRcate' which is not available

Summary

Package: ChAMP
Version: 2.25.0
Command: C:\cygwin\bin\curl.exe -O http://155.52.207.165/BBS/3.15/bioc/src/contrib/ChAMP_2.25.0.tar.gz && rm -rf ChAMP.buildbin-libdir && mkdir ChAMP.buildbin-libdir && D:\biocbuild\bbs-3.15-bioc\R\bin\R.exe CMD INSTALL --merge-multiarch --build --library=ChAMP.buildbin-libdir ChAMP_2.25.0.tar.gz && D:\biocbuild\bbs-3.15-bioc\R\bin\R.exe CMD INSTALL ChAMP_2.25.0.zip && rm ChAMP_2.25.0.tar.gz ChAMP_2.25.0.zip
StartedAt: 2021-11-29 19:46:07 -0500 (Mon, 29 Nov 2021)
EndedAt: 2021-11-29 19:49:04 -0500 (Mon, 29 Nov 2021)
EllapsedTime: 177.6 seconds
RetCode: 0
Status:   OK  

Command output

##############################################################################
##############################################################################
###
### Running command:
###
###   C:\cygwin\bin\curl.exe -O http://155.52.207.165/BBS/3.15/bioc/src/contrib/ChAMP_2.25.0.tar.gz && rm -rf ChAMP.buildbin-libdir && mkdir ChAMP.buildbin-libdir && D:\biocbuild\bbs-3.15-bioc\R\bin\R.exe CMD INSTALL --merge-multiarch --build --library=ChAMP.buildbin-libdir ChAMP_2.25.0.tar.gz && D:\biocbuild\bbs-3.15-bioc\R\bin\R.exe CMD INSTALL ChAMP_2.25.0.zip && rm ChAMP_2.25.0.tar.gz ChAMP_2.25.0.zip
###
##############################################################################
##############################################################################


  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  1 5940k    1 95635    0     0   496k      0  0:00:11 --:--:--  0:00:11  494k
100 5940k  100 5940k    0     0  9195k      0 --:--:-- --:--:-- --:--:-- 9181k
only one architecture so ignoring '--merge-multiarch'
* installing *source* package 'ChAMP' ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Warning message:
replacing previous import 'minfi::getMeth' by 'bsseq::getMeth' when loading 'DMRcate' 
No methods found in package 'RSQLite' for request: 'dbListFields' when loading 'lumi'
Warning: replacing previous import 'plyr::summarise' by 'plotly::summarise' when loading 'ChAMP'
Warning: replacing previous import 'plyr::rename' by 'plotly::rename' when loading 'ChAMP'
Warning: replacing previous import 'plyr::arrange' by 'plotly::arrange' when loading 'ChAMP'
Warning: replacing previous import 'plyr::mutate' by 'plotly::mutate' when loading 'ChAMP'
Warning: replacing previous import 'plyr::is.discrete' by 'Hmisc::is.discrete' when loading 'ChAMP'
Warning: replacing previous import 'plyr::summarize' by 'Hmisc::summarize' when loading 'ChAMP'
Warning: replacing previous import 'plotly::subplot' by 'Hmisc::subplot' when loading 'ChAMP'
Warning: replacing previous import 'GenomicRanges::sort' by 'globaltest::sort' when loading 'ChAMP'
Warning: replacing previous import 'plotly::last_plot' by 'ggplot2::last_plot' when loading 'ChAMP'
Warning: replacing previous import 'globaltest::model.matrix' by 'stats::model.matrix' when loading 'ChAMP'
Warning: replacing previous import 'globaltest::p.adjust' by 'stats::p.adjust' when loading 'ChAMP'
Note: possible error in 'dmrcate(myannotation, ': unused argument (mc.cores = cores) 
** help
*** installing help indices
  converting help for package 'ChAMP'
    finding HTML links ... done
    Block.GUI                               html  
    ChAMP-package                           html  
    CpG.GUI                                 html  
    DMP.GUI                                 html  
    DMR.GUI                                 html  
    QC.GUI                                  html  
    champ.Block                             html  
    champ.CNA                               html  
    champ.DMP                               html  
    champ.DMR                               html  
    champ.GSEA                              html  
    champ.QC                                html  
    champ.SVD                               html  
    champ.ebGSEA                            html  
    champ.filter                            html  
    champ.import                            html  
    champ.impute                            html  
    champ.load                              html  
    champ.norm                              html  
    champ.process                           html  
    champ.refbase                           html  
    champ.runCombat                         html  
** building package indices
** installing vignettes
** testing if installed package can be loaded from temporary location
Warning: replacing previous import 'minfi::getMeth' by 'bsseq::getMeth' when loading 'DMRcate'
No methods found in package 'RSQLite' for request: 'dbListFields' when loading 'lumi'
Warning: replacing previous import 'plyr::summarise' by 'plotly::summarise' when loading 'ChAMP'
Warning: replacing previous import 'plyr::rename' by 'plotly::rename' when loading 'ChAMP'
Warning: replacing previous import 'plyr::arrange' by 'plotly::arrange' when loading 'ChAMP'
Warning: replacing previous import 'plyr::mutate' by 'plotly::mutate' when loading 'ChAMP'
Warning: replacing previous import 'plyr::is.discrete' by 'Hmisc::is.discrete' when loading 'ChAMP'
Warning: replacing previous import 'plyr::summarize' by 'Hmisc::summarize' when loading 'ChAMP'
Warning: replacing previous import 'plotly::subplot' by 'Hmisc::subplot' when loading 'ChAMP'
Warning: replacing previous import 'GenomicRanges::sort' by 'globaltest::sort' when loading 'ChAMP'
Warning: replacing previous import 'plotly::last_plot' by 'ggplot2::last_plot' when loading 'ChAMP'
Warning: replacing previous import 'globaltest::model.matrix' by 'stats::model.matrix' when loading 'ChAMP'
Warning: replacing previous import 'globaltest::p.adjust' by 'stats::p.adjust' when loading 'ChAMP'
** testing if installed package can be loaded from final location
Warning: replacing previous import 'minfi::getMeth' by 'bsseq::getMeth' when loading 'DMRcate'
No methods found in package 'RSQLite' for request: 'dbListFields' when loading 'lumi'
Warning: replacing previous import 'plyr::summarise' by 'plotly::summarise' when loading 'ChAMP'
Warning: replacing previous import 'plyr::rename' by 'plotly::rename' when loading 'ChAMP'
Warning: replacing previous import 'plyr::arrange' by 'plotly::arrange' when loading 'ChAMP'
Warning: replacing previous import 'plyr::mutate' by 'plotly::mutate' when loading 'ChAMP'
Warning: replacing previous import 'plyr::is.discrete' by 'Hmisc::is.discrete' when loading 'ChAMP'
Warning: replacing previous import 'plyr::summarize' by 'Hmisc::summarize' when loading 'ChAMP'
Warning: replacing previous import 'plotly::subplot' by 'Hmisc::subplot' when loading 'ChAMP'
Warning: replacing previous import 'GenomicRanges::sort' by 'globaltest::sort' when loading 'ChAMP'
Warning: replacing previous import 'plotly::last_plot' by 'ggplot2::last_plot' when loading 'ChAMP'
Warning: replacing previous import 'globaltest::model.matrix' by 'stats::model.matrix' when loading 'ChAMP'
Warning: replacing previous import 'globaltest::p.adjust' by 'stats::p.adjust' when loading 'ChAMP'
** testing if installed package keeps a record of temporary installation path
* MD5 sums
packaged installation of 'ChAMP' as ChAMP_2.25.0.zip
* DONE (ChAMP)
* installing to library 'D:/biocbuild/bbs-3.15-bioc/R/library'
package 'ChAMP' successfully unpacked and MD5 sums checked